• Resolved Gabriel Novo

    (@gjnovo)


    Updated the Jetpack plugin to the latest version and my entire site became unreachable.

    At first the error was: Briefly unavailable for scheduled maintenance. Check back in a minute.

    Now I’m getting the following:

    Warning: require_once(/home/edfisher1/public_html/gabrielnovo.com/wp-content/plugins/jetpack/class.jetpack-user-agent.php): failed to open stream: No such file or directory in /home/edfisher1/public_html/gabrielnovo.com/wp-content/plugins/jetpack/jetpack.php on line 78
    
    Fatal error: require_once(): Failed opening required '/home/edfisher1/public_html/gabrielnovo.com/wp-content/plugins/jetpack/class.jetpack-user-agent.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/edfisher1/public_html/gabrielnovo.com/wp-content/plugins/jetpack/jetpack.php on line 78

    This is a first for me. Jetpack was the one plugin I could consistently count on to update without a hitch.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I had a this problem, too, and was shocked that JetPack, of all plugins, could caused a fatal error! I fixed it by accessing the site via FTP and disabling the JetPack plugin by renaming the plug-in folder. Then I logged into the WP Admin page, deleted the plug-in and reinstalled it fresh. It seems to be fine now. I hope this helps.

    Thread Starter Gabriel Novo

    (@gjnovo)

    @mgc your workaround got my site back up. THANK YOU!

    Interestingly, now Jetpack isn’t connecting to WordPress.com. It sees my account and looks like it connected, but then asks me to pick a plan. I’ve had Jetpack and Akismet since forever and was grandfathered in with the original SPAM protection setup.

    No clue why that’s popping up, but it’s preventing Jetpack from truly activating. An odd development that hopefully the developers can clear up.

    I’m happy to help, my friend. πŸ™‚

    I’m not a developer, so I don’t have more answers, but glad to know my fix was useful. The JetPack developers seem to be very responsive, so hopefully they’ll chime in soon. Take care!

    Cheers,
    Michael

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @gjnovo It appears that the update didn’t complete on your site; some Jetpack files were missing from your WordPress installation thus causing an error. Reinstalling from scratch, as @mgc, would solve the issue.

    It sees my account and looks like it connected, but then asks me to pick a plan. I’ve had Jetpack and Akismet since forever and was grandfathered in with the original SPAM protection setup.

    When you see the screen asking you to pick a plan, you can pick the free plan (that’s the default) to complete your connection to WordPress.com.

    Thread Starter Gabriel Novo

    (@gjnovo)

    @jeherve I saw the option to pick a plan, but was worried it would override my grandfathered Akismet protection.

    If it doesn’t affect my current SPAM screening through Akismet then I’ll gladly pick a plan to finish the connection.

    There’s something else going on here. I have four sites (out of ~100) that are down with Jetpack 4.8. All four have the same problem:

    — Renaming the plugin folder brings the site back up
    — Uploading 4.8 fresh via FTP didn’t solve.
    — Once disabled, I can’t activate 4.8 because “Plugin could not be activated because it triggered a fatal error.”
    — WP-DEBUG simply hides the 500 message and gives a 100% (including source) blank screen. No other error messages found. Nothing in the server error logs either.
    — Pushing 4.7.1 back up to the sites fixes it.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Picking the free plan won’t override your existing Akismet plan. If you actually purchase a Jetpack plan, however, your Akismet plan will indeed be overwritten.

    Did a bit more digging and can’t find much to go on. All four sites are on different hosts, different themes, and all have a fairly limited set of plugins (10ish).

    There is a loop between my site and wordpress.com. At wordpress.com it said connected but in my dashboard could not.

    Thread Starter Gabriel Novo

    (@gjnovo)

    @sunipeyk I deactivated and reactivated the Jetpack plugin in order to fix that loop. It took a couple of tries (could’ve been cache or cookies), but it worked in the end.

    That’s not correct @jeherve – I tried a re-install and it still produces a fatal error.

    Holy cow Automattic – this is going to be a NIGHTMARE for people like me with automatic updates on 100+ sites. Fix this NOW or pull it – this is the one plugin that can’t go down because you’ve tied so much into it.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @mickmel @farlane Your issues may be different from the ones reported on this thread. If you experience repeated fatal errors, even after reinstalling, you may be running into the issue outlined here:
    https://wordpress.org/support/topic/jetpack-4-8-on-multisite-white-screens-some-but-not-all/

    It’s not multisite in my case. Just two sites on the same server which is still in the 5.xx PHP.

Viewing 14 replies - 1 through 14 (of 14 total)

The topic ‘Updated Plugin and Site is Down (Fatal Error)’ is closed to new replies.