• Resolved rainsey

    (@rainsey)


    hi, in the new update we’re unable to save plugin unloads as the following error prompts:

    Something went wrong. You may need to refresh the page and try again, but you will lose all your changes

    disabling plugins on wordpress > pages works fine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jose Mortellaro

    (@giuse)

    Hi @rainsey,

    Theoretically, the latest update of the plugin should have no impact on the saving process, but I can’t rule out that I’m missing something. In any case, nobody else has reported the same issue so far.

    When you save the settings, the plugin checks a nonce. The nonce is a unique code that expires after a few hours. Are you sure you didn’t click the save button after leaving the page open for several hours?

    Have you tried refreshing the page and saving again?

    Does this happen on all FDP backend pages? If not, on which pages does it happen?

    Best regards

    Jose

    Thread Starter rainsey

    (@rainsey)

    Hi Jose,

    I’ve tried on our staging and live site with the same results. On our staging site I tested previous versions and the same error occurs saving data.

    ive also removed and reinstalled the plugin and a reset of the settings which both gave the same error. There are no errors in the console using a private browser.

    i’ll test further without other plugins and litespeed cache. I cannot recall any recent updates other than WordPress and WooCommerce.

    The error occurs on all backend pages within the plugin, but not on pages > disable plugins in WordPress. The se behaviour occured after resetting the settings (no disables) , reinstall and reactivating the plugin.

    thanks for the assistance

    Plugin Author Jose Mortellaro

    (@giuse)

    Hi @rainsey

    thank you for the information.

    Can you please enable the debugging in wp-config.php and let me know if you see any errors in wp-content/debug.log when you save the FDP settings?

    If you need more details about the debugging you can read this article: https://freesoul-deactivate-plugins.com/how-to-enable-debugging-in-wordpress-a-step-by-step-guide/

    Best regards

    Jose

    Thread Starter rainsey

    (@rainsey)

    hi @giuse,

    The issue was in our theme functions file with code to increase security nonces to 1 day (not 4hrs). Removing this fixed the issue within the plugin.

    Thanks

    Plugin Author Jose Mortellaro

    (@giuse)

    Hi @rainsey

    many thanks for the information.

    Best regards

    Jose

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.