WordPress.org

Plugin Directory

Church Theme Content

Provides compatible themes with sermon, event, person and location post types, taxonomies and fields. Requires a compatible theme for showing content.

Who this is for

This plugin is intended for a very specific audience. If you are not one of the below then this plugin will not be useful to you.

  • Users of official themes from churchthemes.com
  • Users of third-party themes from other providers made specifically for this plugin
  • Theme developers wanting to improve data portability for church sites

What it does

It enables users to manage sermons, events, people and locations to be displayed by a compatible theme.

Experienced WordPress developers agree that functionality like this does not belong in themes since themes are intended only for controlling the appearance of a WordPress site. Content that users might expect to take with them if they switch themes should "live" in a plugin in order to avoid theme lock-in. Similarly, our approach is not to present content using the plugin since themes offer more control for that purpose. This is why a compatible theme is required.

See the Plugin Details on churchthemes.com for a tour of features. Read the User Guide for instructions.

Compatible Themes

A compatible theme is required for presenting content.

Add-ons

Users can optionally install add-ons for additional features.

Developers

Please see the Developer Guide on churchthemes.com for notes on developing themes that use this plugin. A couple benefits are that you will save time and be helping to accomplish better data portability among church websites powered by WordPress.

You can follow development on GitHub.

Translations

Several translations are included with this plugin, including English, Spanish, German, French, Portuguese, Swedish and Dutch. See the Translations section in the plugin's user guide for the most up-to-date list.

Follow us

Requires: 3.6 or higher
Compatible up to: 4.3
Last Updated: 2015-8-10
Active Installs: 4,000+

Ratings

4.8 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1