WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

BestAzon - Localize Amazon Links

Automatically convert all Amazon links into global affiliate links, and direct visitors to their local Amazon stores. FREE, FAST, NO SIGNUP NEEDED.

This plugin will localize all your Amazon links, and add your affiliate IDs to the links. All features are for free, and work out of the box, no signups needed!

That means a better experience for your visitors, and more commission income for you.

Check out the demo for BestAzon

What makes BestAzon the ideal plugin for any site using Amazon Affiliate Links

  1. Free: The BestAzon plugin for WordPress is free to use, and will remain free – no feature will ever be locked.
  2. Automatic Amazon Link Localization: Automatically converts any Amazon link to a global link that will redirect the visitor to the Amazon Website in that country. Thus, you do not lose commission on such visitors. You'll see an immediate bump in your Amazon commissions upon installing BestAzon.
  3. No registration needed: No need to register on another website or API – the plugin does what it’s supposed to out of box without making you jump hoops and asking for your information.
  4. Fastest: Every milliseond matters while redirecting vistors to local stores. We serve from edge nodes across the world - meaning 100% uptime, and the redirect takes less than 0.4 seconds on average.
  5. Covers all Amazon Stores: Supports all Amazon stores worldwide
  6. Works for all Amazon Links: Works for product pages, search pages, category pages and homepages. Works for long url (Amazon....) as well as short URL (amzn.to). Even works for Amazon links which are redirected through another link redirecting service (such as prettylinks, or bitly).
  7. Automatic Affiliate Linking: Automatically converts any Amazon link to an affiliate link with your affiliate ID for the country the visitor is from.
  8. Flexible: Tons of additional options for advanced users

BestAzon is available for non wordpress sites too!

Requires: 3.0.1 or higher
Compatible up to: 4.7.1
Last Updated: 5 days ago
Active Installs: 700+

Ratings

4 out of 5 stars

Support

3 of 5 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,2,2
100,1,1 100,1,1
100,1,1
100,1,1