WordPress.org

Ready to get started?Download WordPress

Forums

WP Display Header
[resolved] SSL/HTTPS Breaks Images on Appearance > Header Page (7 posts)

  1. fwchapman
    Member
    Posted 1 year ago #

    I really like this plugin and am using it on a couple of client sites. Unfortunately, I'm having this problem on a site which uses a shared SSL certificate to secure logins and administration over HTTPS: on the Appearance > Header page, all of the images are broken, including the header preview image and all of the thumbnails. I temporarily downgraded site security by eliminating the SSL certificate and doing administration over ordinary HTTP, and that temporarily eliminated the problem.

    Securing WordPress logins and administration over HTTPS with a shared SSL certificate requires different settings for the siteurl and home entries of the options table in the WordPress database. I generally use something like this:

    options > siteurl: http://SERVER.WEBHOST.com/~ACCOUNT

    options > home: http://www.MYDOMAIN.com

    I also use the WordPress HTTPS (SSL) plugin to configure WordPress to use HTTPS for logins and administration. The shared SSL certificate is invoked via

    https://SERVER.WEBHOST.com

    Can you please fix this issue in a future release?

    Thanks for a great plugin,

    Fred Chapman

    http://wordpress.org/extend/plugins/wp-display-header/

  2. fwchapman
    Member
    Posted 1 year ago #

    P.S. In the page/post edit screen, the plugin serves header image thumbnails over HTTP rather than HTTPS, and everything works fine there.

  3. fwchapman
    Member
    Posted 1 year ago #

    P.P.S. An easy way to fix the broken images on the Appearance > Header page might be to serve images using root-relative paths. Omitting the HTTP or HTTPS protocol and the domain name completely could clear this up.

  4. Konstantin Obenland
    Theme Wrangler
    Plugin Author

    Posted 1 year ago #

    Thanks for bringing the issue to my attention!
    I opened an issue on GitHub and will look into it for the next update.

  5. fwchapman
    Member
    Posted 1 year ago #

    Thank you, Konstantin!

  6. fwchapman
    Member
    Posted 1 year ago #

    SOLUTION

    I found a way to solve my problem by choosing my image paths more carefully. First, I went into

    Settings > Media > Full URL path to files

    and changed the URL so that it uses the domain for the SSL host. I then updated the HEADER_URL in my theme's functions.php file. Finally, I used the Search and Replace plugin to safely update existing image URLs in the post_content and guid fields of the _posts table and the meta_value field of the _postmeta table.

    Problem solved!

  7. stephanmonecke
    Member
    Posted 4 months ago #

    The solution vanished with the deletion of Full URL path to files with WordPress 3.5! :-(

    My header-image is also broken using ssl.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic