wpcork
Forum Replies Created
-
Forum: Plugins
In reply to: [CF7 to Webhook] Use submission ID to pick email addressHi Mário,
Thanks for your response and the complexity is caused by the user wanting to alternate between two different email addresses, where each address gets every second email.
It looks like I’m going to need to install Flamingo, which will give me access to an auto-incrementing submission ID. I can use that along with the “wpcf7_before_send_mail” hook to check if the ID is even or odd. Then the even numbers can be sent to one email and the odd numbers can be sent to the other email.
It would look something like this…
add_action( 'wpcf7_before_send_mail', 'wpcf7_change_recipient' );
function wpcf7_change_recipient($contact_form){
$submission = WPCF7_Submission::get_instance();
$recipient = "email_1_@emailaddress.com" //set email address
if ($mail[_serial_number] % 2 == 0) {
$recipient = "email_2_@emailaddress.com" //change email address if ID is even
}
if($recipient) {
$mail = $contact_form->prop( 'mail' );
$mail['recipient'] = $recipient;
$contact_form->set_properties(array('mail'=>$mail));
}
}If there’s a better way to do this, please let me know.
Hi Rogier,
It’s the original error that I’m seeing…
Due to your server or website configuration it is not possible to track statistics.
There are no errors in the console log and there is one error in the php error log…
[18-Mar-2024 14:04:21 UTC] Cron reschedule event error for hook: rsssl_every_five_minutes_hook, Error code: invalid_schedule, Error message: Event schedule does not exist., Data: {“schedule”:”rsssl_five_minutes”,”args”:[],”interval”:300}
Does this help?
– DonalHi Rogier,
I’ve updated to the latest version of your plugin (1.5.7) but I’m still seeing the error.
It looks like it’s recording visitors and page views, but is there something I can do about the error?
Thanks again,
Donal- This reply was modified 2 years, 6 months ago by wpcork.
Thanks Rogier,
It’s not urgent, so I’ll wait for the updated version to be issued next week. If it means anything, I also got these pop-up messages…
Hi Rogier,
Here are the errors that were displayed in the admin area. I’ve left the WP Debug enabled so that you can see the errors on the front end when you visit the site.WordPress database error: [Specified key was too long; max key length is 1000 bytes]
CREATE TABLE wpwa_burst_statistics (IDint NOT NULL AUTO_INCREMENT ,page_urlvarchar(255) NOT NULL,timeint NOT NULL,uidvarchar(255) NOT NULL,time_on_pageint,entire_page_urlvarchar(255) NOT NULL,page_idint NOT NULL,referrervarchar(255),browservarchar(255),browser_versionvarchar(255),platformvarchar(255),devicevarchar(255),device_resolutionvarchar(255),session_idint,first_time_visittinyint,bouncetinyint DEFAULT 1, PRIMARY KEY (ID), INDEX time_index (time), INDEX bounce_index (bounce), INDEX page_url_index (page_url), INDEX session_id_index (session_id), INDEX time_page_url_index (time,page_url) ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ciWordPress database error: [Specified key was too long; max key length is 1000 bytes]
CREATE TABLE wpwa_burst_summary (IDint NOT NULL AUTO_INCREMENT ,dateDATE NOT NULL,page_urlvarchar(255) NOT NULL,sessionsint NOT NULL,visitorsint NOT NULL,first_time_visitorsint NOT NULL,pageviewsint NOT NULL,bouncesint NOT NULL,avg_time_on_pageint NOT NULL,completedtinyint NOT NULL, UNIQUE KEY unique_date_page_url (date, page_url), INDEX page_url_date_index (page_url, date), INDEX date_index (date), PRIMARY KEY (ID) ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ciHi Rogier,
Thanks for the fast response and I can confirm that your visit was not captured. I’ve attached a screenshot that I took just now showing zero visits.
Also, I didn’t exclude any IP addresses and the plugin setup is just “out of the box”.

– Donal
Forum: Plugins
In reply to: [UpdraftPlus: WP Backup & Migration Plugin] Identify Attached Dropbox AccountHi vupdraft,
I can see the Dropbox account owners name there. It doesn’t give me the associated email address, but it’s great that I now have a person to contact about the Dropbox account.
Thanks for your help, it’s greatly appreciated,
Donal- This reply was modified 2 years, 11 months ago by wpcork. Reason: Marking as resolved
Forum: Plugins
In reply to: [UpdraftPlus: WP Backup & Migration Plugin] Identify Attached Dropbox AccountHi Vupdraft,
I’ve looked at the Updraft backup log file and it doesn’t identify the Dropbox account being used. Below is an extract of the log file where Dropbox is mentioned (I’ve removed session ID’s etc, where necessary…
0010.722 (0) Beginning dispatch of backup to remote (dropbox) (instance identifier random-text-identifier-replaced-with-this-text) 0010.723 (0) Dropbox: begin cloud upload (using API version 2 with OAuth v2 token) 0010.734 (0) Dropbox: access gained; setting chunk size to: 1024 KB 0011.078 (0) Dropbox: quota usage: used=379402.1 MB, total=2101248 MB, available=1721845.9 MB 0011.081 (0) Dropbox: Attempt to upload: backup_2023-09-30-1458_ text-identifier-replaced-with-this-text -plugins.zip to: backup_2023-09-30-1458_sheelaghbroderickcom_65a0b8471a6d-plugins.zip 0011.891 (0) Dropbox chunked upload: 2.1 % uploaded (pid_upload_session:ABIG- random-text-identifier-replaced-with-this-text, 1048576, 6144 KB) 0014.131 (0) Dropbox chunked upload: 14.8 % uploaded (pid_upload_session: ABIG- random-text-identifier-replaced-with-this-text, 7340032, 10240 KB) 0016.178 (0) Dropbox chunked upload: 35.9 % uploaded (pid_upload_session: ABIG- random-text-identifier-replaced-with-this-text, 17825792, 10240 KB) 0018.314 (0) Dropbox chunked upload: 57 % uploaded (pid_upload_session: ABIG- random-text-identifier-replaced-with-this-text, 28311552, 10240 KB) 0026.229 (0) Recording as successfully uploaded: backup_2023-09-30-1458_ text-identifier-replaced-with-this-text -plugins.zip 0026.254 (0) Deleting local file: backup_2023-09-30-1458_ text-identifier-replaced-with-this-text -plugins.zip: OK 0026.256 (0) Dropbox: File upload success (backup_2023-09-30-1458_ text-identifier-replaced-with-this-text -plugins.zip): 48506 KB in 15s (3196 KB/s)- This reply was modified 2 years, 11 months ago by wpcork.
Hi,
I’ve found that it seemsto be Cartflows that is causing the issue, as I’ve tried updating each plugin individually and it only fails when I go above version 1.5.10 of Cartflows.
I’ve reached out the developers and we’re going to try to clarify definatively if this is a Cartflows issue or not.
That rules out the WC Stripe Gateway, so I’m going to close this topic now.
Thanks again for your help in getting this far.
Best Regards,
DonalHi @solstudioim,
I’ve rules out 1 of the three possible causes (WooCommerce 5.6.0) and I’ll be checking the other two next week, so if you don’t mind I’d like to keep this open for another few days.
-Donal
Forum: Plugins
In reply to: [WooCommerce] Payments Failing & Not Showing Failed Transaction in StripeHi Maykato,
I’ve rules out 1 of the three possible causes (WooCommerce 5.6.0) and I’ll be checking the other two next week, so if you don’t mind I’d like to keep this open for another few days.
-Donal
No Problem,
Here’s a link to a short video that shows how the 500 error occurs when the new Divi Critical CSS is set to a level that includes the trigger for the flipbook modal.
The level is the “above the fold” height to be included when calculating how much css is to be deferred.https://www.dropbox.com/s/rmy7926a3lejh9p/3D%20Flipbook%20Issue.mp4?dl=0
Forum: Plugins
In reply to: [WooCommerce] Payments Failing & Not Showing Failed Transaction in StripeHi Abwaita,
It could still be a problem with WooCommerce as the way I stopped the issue was…
1. I rolled back WooCommerce from 5.6.0 to 5.5.2
2. I rolled back WC Stripe Gateway from 5.4.0 to 4.4.0
3. I rolled back Cartflows plugin from 1.7.0 to 1.5.10These were the versions that were in place a week before the failed payments issue started to appear, so it could be either of these plugins, or a combination of each.
Testing will take a while as I’ll need to change each plugin individually and I’ll post an update here if I find which plugin is causing the issue.
- This reply was modified 5 years, 1 month ago by wpcork.
Hi,
I’ve made three changes that appear to have fixed the issue and over the next week or so I’ll be able to test which one is causing the issue…
1. I rolled back WooCommerce from 5.6.0 to 5.5.2
2. I rolled back WC Stripe Gateway from 5.4.0 to 4.4.0
3. I rolled back Cartflows plugin from 1.7.0 to 1.5.10These were the versions that were in place a week before the failed payments issue started to appear.
Testing will take a while as I’ll need to change each plugin individually and I’ll post an update here if I find which plugin is causing the issue.
Hi,
Thanks for the info, and I can reach out to Divi developers about their error.
What about the WooCommerce error…
2021-08-17T16:05:51+00:00 CRITICAL Uncaught Error: Class 'WC_Structured_Data' not found in /home/airmedica/public_html/wp-content/plugins/woocommerce/includes/class-woocommerce.php:616 Stack trace: #0 /home/airmedica/public_html/wp-includes/class-wp-hook.php(292): WooCommerce->init('') #1 /home/airmedica/public_html/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array) #2 /home/airmedica/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #3 /home/airmedica/public_html/wp-settings.php(560): do_action('init') #4 /home/airmedica/public_html/wp-config.php(102): require_once('/home/airmedica...') #5 /home/airmedica/public_html/wp-load.php(37): require_once('/home/airmedica...') #6 /home/airmedica/public_html/wp-blog-header.php(13): require_once('/home/airmedica...') #7 /home/airmedica/public_html/index.php(17): require('/home/airmedica...') #8 {main} thrown in /home/airmedica/public_html/wp-content/plugins/woocommerce/includes/class-woocommerce.php on line 616