waldopepper
Forum Replies Created
-
Thanks, I have submitted the form π
Forum: Networking WordPress
In reply to: Multisite site icon (link preview)Ah found it thanks! I must have looked at the theme customise options a hundred times! There is a main logo option which is working correctly, then a button underneath this to upload a ‘Light’ logo version (I was ignoring this because the class for the problem image was ‘dark’.
It was this that fixed it, it must have had a value in there, but wasn’t displaying the image set .. I guess also because it was originally uploaded as http:// (probably before we activated our site certificate).
Thanks!
Forum: Fixing WordPress
In reply to: 500 error when accessing wp-adminHi, THANK YOU so much for this, doing the above and re-uploading WordPress did trigger an upgrade and let me get into the Dashboard. I have been re-installing everything since, weirdly with plugins all back, the site didn’t error but was still just showing the menu and no page content.
I read online that the debug errors showing e.g. Fatal error: Uncaught Error: [] operator not supported for strings in Revslider plugin is sometimes caused by the PHP version not working, I dropped this down a few versions but it still wasn’t working. After leaving it overnight, it’s now showing everything except Revslider (slideshow) content so we’re almost there!
Thanks again for your help, I wouldn’t have been able to make any headway without at least getting back to the dashboard.
Forum: Networking WordPress
In reply to: Media library saving images in strange directoriesThanks for the suggestion, this is something that is being caused by a plugin that clones sites in our Multisite network. Not sure why it’s happening but I have worked out how to fix this in the database table anyways!
If anyone is interested, the sitename was being appended to the end of the uploads directory so I changed it on the database:
update databasename.wp_5_options set option_value =’/home/username/public_html/wp-content/uploads’ where option_name like ‘%upload_path%’
Hi again, thank you so much for your support. I just had to learn how to access my databases and how WordPress creates new WP_# tables for each new subsite!
The upload_path wasn’t blank in the WordPress site it was cloned from, but it was set to this:
[details removed]/public_html/wp-content/uploadsIn the cloned multisite it was this value:
…/public_html/wp-content/uploads/sites/5So I changed it to:
…/public_html/wp-content/uploadsand media uploads are now working great! Is this something that might have broken anything else on the WP cloned site? Nothing else seems affected, I just want to be sure it’s all OK as this one will be used as a template for other sites. If it’s likely just to do with the Media Library URLs then I can just fix this each time if it happens again with further clones π
Hi, the site is available now and the media issue is happening on this site too.
It has saved a test file in:
/wp-content/uploads/sites/5/sites/5/2020/03/test.jpgBut is looking for:
/wp-content/uploads/sites/5/2020/03/test.jpgThanks π Emailed you the log and just waiting for the DNS to activate for the subdomain so I can test if this has happened again on the new test site.
Forum: Networking WordPress
In reply to: Multisite 500 errorClosing the topic as resolved, thanks for your time looking into this.
Forum: Networking WordPress
In reply to: Multisite 500 errorHi, sorry for the trouble, I was also chatting with the Hosting provider and they are telling me that they don’t support WordPress Multisite at all! I was given a host to install this on and didn’t realise that not all support this π
Thanks for your help anyways, we’ll look for another provider that can help with this type of structure.
Forum: Networking WordPress
In reply to: Multisite 500 errorAh OK, here’s our htaccess file:
# BEGIN WordPress # The directives (lines) between <code>BEGIN WordPress</code> and <code>END WordPress</code> are # dynamically generated, and should only be modified via WordPress filters. # Any changes to the directives between these markers will be overwritten. <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] # add a trailing slash to /wp-admin RewriteRule ^wp-admin$ wp-admin/ [R=301,L] RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^ - [L] RewriteRule ^(wp-(content|admin|includes).*) $1 [L] RewriteRule ^(.*\.php)$ $1 [L] RewriteRule . index.php [L] </IfModule> # END WordPress # Wordfence WAF <Files ".user.ini"> <IfModule mod_authz_core.c> Require all denied </IfModule> <IfModule !mod_authz_core.c> Order deny,allow Deny from all </IfModule> </Files> # END Wordfence WAFForum: Networking WordPress
In reply to: Multisite 500 errorWell the debug.log doesn’t add any new lines each time I browse to the subdomain URLS, but it does have a lot of warnings about themes and Woocommerce, maybe normal?
The URLS are weird, maybe I should remove and re-install Woocommerce (maybe multisite messed with it or the URL structure?)
/customers/c/2/3/totallylocallyshop.org/httpd.www/wp-content/themes/flatsome/inc/woocommerce/structure-wc-category-page.phpAnyways, it doesn’t feel as though these errors are related to accessing the subdomains
[20-Mar-2020 11:28:48 UTC] PHP Deprecated: Function create_function() is deprecated in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-content/themes/flatsome/inc/woocommerce/structure-wc-category-page.php on line 17 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Cart::get_cart_url is <strong>deprecated</strong> since version 2.5! Use wc_get_cart_url instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Cart::get_cart_url is <strong>deprecated</strong> since version 2.5! Use wc_get_cart_url instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Product::get_gallery_attachment_ids is <strong>deprecated</strong> since version 3.0! Use WC_Product::get_gallery_image_ids instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648 [20-Mar-2020 11:28:50 UTC] PHP Notice: id was called <strong>incorrectly</strong>. Product properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/flatsome/page-blank.php'), the_content, apply_filters('the_content'), WP_Hook->apply_filters, flatsome_contentfix, do_shortcode, preg_replace_callback, do_shortcode_tag, ux_products, wc_get_template_part, load_template, require('/themes/flatsome/woocommerce/content-product.php'), do_action('flatsome_product_box_actions'), WP_Hook->do_action, WP_Hook->apply_filters, flatsome_lightbox_button, WC_Abstract_Legacy_Product->__get, wc_doing_it_wrong Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 3.0.) in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4986 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Product::get_categories is <strong>deprecated</strong> since version 3.0! Use wc_get_product_category_list instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Product::get_gallery_attachment_ids is <strong>deprecated</strong> since version 3.0! Use WC_Product::get_gallery_image_ids instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648 [20-Mar-2020 11:28:50 UTC] PHP Notice: id was called <strong>incorrectly</strong>. Product properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/flatsome/page-blank.php'), the_content, apply_filters('the_content'), WP_Hook->apply_filters, flatsome_contentfix, do_shortcode, preg_replace_callback, do_shortcode_tag, ux_products, wc_get_template_part, load_template, require('/themes/flatsome/woocommerce/content-product.php'), do_action('flatsome_product_box_actions'), WP_Hook->do_action, WP_Hook->apply_filters, flatsome_lightbox_button, WC_Abstract_Legacy_Product->__get, wc_doing_it_wrong Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 3.0.) in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4986 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Product::get_categories is <strong>deprecated</strong> since version 3.0! Use wc_get_product_category_list instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Product::get_gallery_attachment_ids is <strong>deprecated</strong> since version 3.0! Use WC_Product::get_gallery_image_ids instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648 [20-Mar-2020 11:28:50 UTC] PHP Notice: id was called <strong>incorrectly</strong>. Product properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/flatsome/page-blank.php'), the_content, apply_filters('the_content'), WP_Hook->apply_filters, flatsome_contentfix, do_shortcode, preg_replace_callback, do_shortcode_tag, ux_products, wc_get_template_part, load_template, require('/themes/flatsome/woocommerce/content-product.php'), do_action('flatsome_product_box_actions'), WP_Hook->do_action, WP_Hook->apply_filters, flatsome_lightbox_button, WC_Abstract_Legacy_Product->__get, wc_doing_it_wrong Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 3.0.) in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4986 [20-Mar-2020 11:28:50 UTC] PHP Notice: WC_Product::get_categories is <strong>deprecated</strong> since version 3.0! Use wc_get_product_category_list instead. in /customers/c/2/3/totallylocallyshop.org/httpd.www/wp-includes/functions.php on line 4648[truncated]
Forum: Networking WordPress
In reply to: Multisite 500 errorThanks for the quick answer and advice!
I renamed .htacess and the main site is unaffected but the subdomains now show this error message
Not Found
The requested URL was not found on this server.Thanks, I didn’t realise the difference between Multisite and NS Cloner. What we are trying to do is have a template subdomain that we can quickly clone and create new subsites from (without having to apply all the same Pages/Themes/settings etc to each one, is this possible with the standard WP Multisite function?)
Forum: Fixing WordPress
In reply to: Permalinks problemThanks – not sure what you mean by ‘required code’ – is there a way of writing what the pages should be called, rather than doing this through the dashboard?