WordPress.org

Forums

[resolved] Yet another htaccess question (17 posts)

  1. colbyolson
    Member
    Posted 6 years ago #

    Im having troubles with turning on pretty permalinks.

    I could not find any .htaccess file, even with "show hidden files" enabled. I tried creating my own file with an empty comment and ftp'ed it to the directory where index.php is, resulting in internal errors.

    Im all out of ideas, unless I need to ask my host about mod_rewrite and AllowOverride, which I just emailed them.

    Any other ideas? Im really all out.

  2. colbyolson
    Member
    Posted 6 years ago #

    Please?

  3. colbyolson
    Member
    Posted 6 years ago #

    Rebump.

  4. whooami
    Member
    Posted 6 years ago #

    Im all out of ideas, unless I need to ask my host about mod_rewrite and AllowOverride, which I just emailed them.

    And while you have been waiting and bumping, have you asked your host? What did they say?

  5. iridiax
    Member
    Posted 6 years ago #

    http://codex.wordpress.org/Using_Permalinks

    What format did you use for your "empty comment"?

  6. colbyolson
    Member
    Posted 6 years ago #

    No reponse from the host yet, they're real fast on that part.

    As for the empty I just created text file with "#empty comment", uploaded it to the main directory and changed the name to .htaccess
    Any htaccess file I upload causes internal errors, so perhaps Im uploading it into the wrong directory?

  7. whooami
    Member
    Posted 6 years ago #

    Any htaccess file I upload causes internal errors, so perhaps Im uploading it into the wrong directory?

    No.

  8. colbyolson
    Member
    Posted 6 years ago #

    So am Im in the dark until my host responds? I sent them another message, hopefully they are faster on this one.

    Thanks whooami for your help so far.

  9. whooami
    Member
    Posted 6 years ago #

    who is your host? theyre colocating, is it these ppl?

    http://www.webintellects.com/

  10. colbyolson
    Member
    Posted 6 years ago #

    webhostgiant.com

    Im not sure if I am pleased with them or not. It takes forever for them to respond to any question I ask.

  11. whooami
    Member
    Posted 6 years ago #

    alright.

    http://whg-billing.secure-wi.com/knowledgebase.php

    there is a question on there, regarding hotlinking.

    blocking horlinkers is done using an .htaccess

    that answer is either going to say something like "create an .htaccess" OR "login to your control panel and .." and that will create an .htaccess OR "you cant block hotlinkers"

    I cant read it, since im not registered, so why dont you login and see what it says.

  12. whooami
    Member
    Posted 6 years ago #

    and you do know they have a support forum? (with no posts)

    hahahaha

  13. colbyolson
    Member
    Posted 6 years ago #

    Their forum has a total of 4 threads combined, each no more than one comment, with no activity what so ever on them.

    As for the hotlinking thread, it reads:

    Bandwidth theft or "hotlinking" is a direct linking to web site's files (images, video, etc.). It can be prevented for example with
    mod_rewrite module. Place rules like below into the vhost.conf or .htaccess files for the needed domain (for example http://www.DOMAIN_NAME.TLD):

    RewriteEngine on
    RewriteCond % !^$
    RewriteCond % !^http://(www\.)?DOMAIN_NAME\.TLD(/)?.*$ [NC]
    RewriteRule \.(gif|jpg|jpeg|png|swf)$ - [NC,F]

    But no where on my site is there a .htaccess file, I am currently looking for something like vhost.conf, (edit: also, with no such luck.)

  14. whooami
    Member
    Posted 6 years ago #

    vhost.conf is an apache configuration file for virtual hosts .. you arent going to find that within your own directory

    But no where on my site is there a .htaccess file

    thats where you come in. You need to create it. I think thats already been determined hasnt it?

  15. Joni
    Member
    Posted 6 years ago #

    You need to create an empty file with a text editor (Microsoft Word is NOT a text editor). If the text editor forces you to do so, name it htaccess.txt. Then FTP it up to your WP root and change its name if necessary. It should have permissions of 666 just long enough for WP to write to it. Then change the permissions back to 644. I thought you'd already created such a file, but maybe I misunderstood you. In any event, the file should be blank/empty and you should just let WP write its content there. What I mean is, upload the empty file, change its name to .htaccess if necessary, CHMOD it to 666, go to your WP dashboard and turn on permalinks, then CHMOD the .htaccess file back to 644.

  16. colbyolson
    Member
    Posted 6 years ago #

    Thank you all for your help, after my studying I will definitely try this and post the results. Thanks guys, I appreciate it.

  17. colbyolson
    Member
    Posted 6 years ago #

    Permalinks now work, thank you Joni. Ends up TextEdit for the mac isnt too great to use, ending up not creating a "blank" htaccess file. I borrowed my girlfriends laptop, made a blank text doc and uploaded it using SmartFTP, and boom, problem solved.

    Thank again for your help guys.

Topic Closed

This topic has been closed to new replies.

About this Topic