WordPress.org

Forums

/wp-admin/admin-post.php Not Found. Can't EXPORT. (8 posts)

  1. frogstar42
    Member
    Posted 10 months ago #

    Tried to export my one and only (gigantic) Tablepress CSV database file. It yields a FILE NOT FOUND error for http://creatingcanadianfamilies.ca/wp-admin/admin-post.php

    Tried default theme, and all plugins inactive except the 5 Tablepress plugins I use. Is my file too big maybe?

  2. TobiasBg
    Member
    Posted 10 months ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    This could indicate the server does not like something in the request. It might indeed be possible that the size of the table results in a lot of memory being used. Some servers then stop the execution and simply return a "404 Not Found" error -- although the file clearly exists.

    Unfortunately, this is nothing that I can influence in TablePress, as it affects the server configuration. I can therefore only suggest that you ask your webhost company about this. They should know the reasons for why the server returns that "Not found" error.

    Regards,
    Tobias

  3. frogstar42
    Member
    Posted 10 months ago #

    Sadly, I am the webhost company, and we've already expanded the memory requirements up to quite huge. This means we're lost. The file is locked in and it can't be exported or imported. OH NO! Hmmm... Seems like an odd error. I'll let this thread know if I figure something out. Maybe I'll delete some entries.

  4. TobiasBg
    Member
    Posted 10 months ago #

    Hi,

    memory was just a guess by me. There might be other reasons in the server configuration that can cause this. It might also be a execution issue, or there's a PHP extension installed that blocks the request for security issues or something like that. You might want to take a look at the server error logs.
    I'm not a Linux expert, so I can't really help with that however :-(

    And no worries, the data is stored in the database as a JSON string, so it's not lost. If the export really doesn't work, we can extract the data from that.

    Regards,
    Tobias

  5. frogstar42
    Member
    Posted 10 months ago #

    Ok. I did some more troubleshooting and now I'm getting some new weird things when I try import or export with zero plugins loaded.

    The IMPORT or EXPORT click yields a themeless white page with some code at the top of the screen. I understand this may be beyond your support, but you've been so helpful in the past.

    http://creatingcanadianfamilies.ca/troubleshoot/

    Screen shots of the weird export page that appears.
    The value of code seems different each time. Just now I saw:

    ': .95, 'position': 'center' }); });
    Skip to toolbar

  6. TobiasBg
    Member
    Posted 10 months ago #

    Hi,

    from what I can see, that code is part of the admin screens of WordPress.
    However, the HTTP request response seems to stop half way, so that not all of the HTML is transmitted. Depending on where the data stops (e.g. right between some JavaScript code), it can not be parsed properly an will there result in a broken-looking page.

    I suggest that you turn off WP_DEBUG in the wp-config.php file to maybe see some error messages there.

    Regards,
    Tobias

  7. frogstar42
    Member
    Posted 10 months ago #

    I seem to have resolved this by replacing the file not found page from a backup. How odd... so we don't know what the issue was, but we fixed it. Weirdness. I'll just blame the client. (grin)

  8. TobiasBg
    Member
    Posted 10 months ago #

    Hi,

    ok, that sounds strange, indeed :-)
    But good that you were able to fix this!

    Best wishes,
    Tobias

Reply

You must log in to post.

About this Topic