[resolved] WordPress does not work after changing permissions. (11 posts)

  1. ready2rockonline
    Posted 6 years ago #

    Hi, While using wordpress built in upgrade plugin, I got an upgrade failed error in wp-includes folder. In my ignorance I changed the file permissions to 775 for the folder, and as a result, the entire blog feel apart. Now nothing shows up at all, I tried changing permissions to 777 for the folder using my ftp client as well but with no result. I need IMMEDIATE help.
    Thanks in advance.

  2. Aaron
    Posted 6 years ago #

    Rename the plugin folder in FTP to deactivate it

    If that doesnt work try logging in to File Manager in cPanel and changing the permissions. Sometimes FTP doesnt work.

  3. ready2rockonline
    Posted 6 years ago #

    @wpbum Tried the file manager approach with Cpanel.. no use there.. same output... rather no output.

  4. Aaron
    Posted 6 years ago #

    The I would go disable all your plugins by renaming the folders in FTP and see what you get.

  5. ready2rockonline
    Posted 6 years ago #

    Hi, ok work done.. Here is what i figured out. The changes in FTP mode take some time to reflect... about 20 mins(gave me a heart attack). A 755 permission base was more than enough for the upgrade. I use wordpress update plugin to get the job done and it worked like a breeze.
    Thanks for the answers folks.

  6. Aaron
    Posted 6 years ago #

    Your welcome. Make sure to mark the thread resolved.

    Wonder if you were just seeing a cached page after you updated permissions.

  7. Samuel B

    Posted 6 years ago #

    do not add a modlook tag to get help - next time topic will be simply deleted

  8. Aaron
    Posted 6 years ago #

    I added modlook tag because a user spammed like 8 threads. A moderator must of deleted the post but didnt remove the tag.

  9. Samuel B

    Posted 6 years ago #

    ok cool - apologies to OP

  10. truwizard
    Posted 6 years ago #

    My site http://wizardspost.com/ is WORKING but a strange problem has appeared.
    I was UPGRADING (auto upgrade)to wordpress latest version 3.0.1 when it stalled ( I think)
    On refreshing it gave the following messages:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '__return_zero' was given in /home/wizard/public_html/wordpress/wp-includes/plugin.php on line 166

    Fatal error: Call to undefined function is_multisite() in /home/wizard/public_html/wordpress/wp-login.php on line 85

    Now I cannot login to my wp-admin.
    Can anyone suggest what I should do.

  11. truwizard
    Posted 6 years ago #

    I downloaded wordpress 3.0.1 and installed it.

    Good result - The page loads and I can also login to http://wizardspost.com/wordpress/wp-admin/ AND see my dashboard. All the links seem to work properly EXCEPT PLUGINS.

    Bad Result - When I click on Plugins on the dashboard I get this error :

    Not Found

    The requested URL /wordpress/wp-admin/plugins.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an Error Document to handle the request.

    On checking the files I note that plugins.php is in wp-admin > includes and another one in wp-includes

    Any suggestions what I should do? Incidentally, I had only ONE plugin active ( adsense-delux.php)
    SAME result when I rename wp-content/plugins folder

Topic Closed

This topic has been closed to new replies.

About this Topic