WordPress.org

Forums

Menubar Widgets
[resolved] Widgets not showing (17 posts)

  1. Just Corin
    Member
    Posted 1 year ago #

    I have downloaded the plugin and added widgets to the 'Menubar Area' in the widgets menu but nothing is showing in the menubar.

    Do I need to do something else to get this working?

    Thanks

    https://wordpress.org/plugins/menubar-widgets/

  2. hadi khosrojerdi
    Member
    Plugin Author

    Posted 1 year ago #

    The first you add widgets to "Menubar Area", then you must active them in the "menu settings" for each menu item through the following address :
    Appearance > Menus

    Screen Shot's

    Please do not forget be active "description" item of " Show advanced menu properties " in " Appearance > Menus ( Screen Options ) ", otherwise the widgets not displayed in menu settings.

    Screen Shot

  3. drycreekweb
    Member
    Posted 8 months ago #

    I am having the same problem as Just Corin and there is no, as you say, Show advanced menu properties" in "Appearance > Menus ( Screen Options )" in the Menu section of the Dashboard at Appearance > Menus.

  4. hadi khosrojerdi
    Member
    Plugin Author

    Posted 7 months ago #

    hi @drycreekweb and thanks for feedback. :)

    If you can see "Menubar Area", but the widgets will not be displayed in "Appearance > Menus" section, so maybe the menubar-widgets plugin be interfering to other plugins or current theme.

    A similar issue reported here.

    I recommend you use this way :

    function overwrite_menubar_widgets_walker() {
        global $Menubar_Widgets_Plugin;
    
        remove_filter("wp_edit_nav_menu_walker", array( $Menubar_Widgets_Plugin, "register_menubar_widgets_walker"), 10 );
        add_filter("wp_edit_nav_menu_walker", array( $Menubar_Widgets_Plugin, "register_menubar_widgets_walker"), 150 );
    }
    add_action( 'after_theme_setup', 'overwrite_menubar_widgets_walker' );
  5. ndesign55
    Member
    Posted 7 months ago #

    Same Issues with my menubar plugin...there is no advanced options nor is there options within each menu item.

  6. hadi khosrojerdi
    Member
    Plugin Author

    Posted 7 months ago #

    hi @ndesign55.

    Have you seen this video?

  7. ndesign55
    Member
    Posted 7 months ago #

    Checked it out, looks like after my updates to wordpress 4 is the underlying reason why Im not finding any luck with the functionality :z

  8. ndesign55
    Member
    Posted 7 months ago #

    Scratch that Hadi, tested on basic WP4 install and MenuBar worked fine. I running Virtue Themes which seems to be the problem at this point...I ran updates and switched back to twenty-twelve theme and everything is looking fine : )

  9. hadi khosrojerdi
    Member
    Plugin Author

    Posted 7 months ago #

    Please send to me your theme to check out and find a solution.
    rss_samuel['at'sign]yahoo.com

  10. drycreekweb
    Member
    Posted 7 months ago #

    I made a Child Theme for the Catch Fire theme and added your php above to the child functions.php file but I see no change.

    I watched the video. I only see the Menubar Area in Appearance > Widgets. I see no Menubar Widgets section in Appearance > Menus. I checked "Description" in the menu options.

  11. hadi khosrojerdi
    Member
    Plugin Author

    Posted 7 months ago #

    I'm sorry @drycreekweb for the delay in submitting this comment. I did not receive any notification for this topic. :(

    Please add the big numbers for third parameter of add_filter function, for example :

    function overwrite_menubar_widgets_walker() {
        global $Menubar_Widgets_Plugin;
    
        remove_filter("wp_edit_nav_menu_walker", array( $Menubar_Widgets_Plugin, "register_menubar_widgets_walker"), 10 );
        add_filter("wp_edit_nav_menu_walker", array( $Menubar_Widgets_Plugin, "register_menubar_widgets_walker"), 500 );
    }
    add_action( 'after_theme_setup', 'overwrite_menubar_widgets_walker' );

    If this did not work for you, i can not help, Unless you send me your theme.

  12. drycreekweb
    Member
    Posted 7 months ago #

    I put the code you just sent into my child theme's functions.php file. I don't understand what "big numbers for third parameter of add_filter function" are. Looks like it is where you put "500". I don't what number I am supposed to put there so I just put it in the way you wrote it to see if anything would happen.

    Sorry, I am a primarily a designer with very limited php knowledge, so I don't understand what your code is doing.

    The theme I am using is: https://wordpress.org/themes/catch-flames (Oops, I told you Catch Fire before, sorry, it's Catch Flames)

    Your plugin looks awesome, I hope we can get it to work!

  13. hadi khosrojerdi
    Member
    Plugin Author

    Posted 7 months ago #

    Thank's @drycreekweb. :)
    You can vote to this plugin, here.

    I checked your theme, there is not any problem to menubar-widgets plugin.
    After put above code on child theme functions.php file, If you still can not see the menubar-widgets section, so there is here a problem to another plugins.

    Please deactivate your plugins for find the plugin that is problematic.

  14. drycreekweb
    Member
    Posted 7 months ago #

    Okay, thank you.

  15. eli_damon
    Member
    Posted 4 months ago #

    Hi, Hadi. Thanks for pointing me to this thread. I don't understand much of it, but I did try disabling other plugins, and it had no effect.

  16. hadi khosrojerdi
    Member
    Plugin Author

    Posted 4 months ago #

    If you don't see the widgets under the menu section, you should to follow this steps:

    1. Tick the "description" checkbox

    Under "Appearance > Menus" page, go to "Screen Options" and tick the "description" checkbox.

    ScreenShot

    then check the menubar-widgets section, if it had not effect, follow next step.

    2. Overwrite the Walker_Menubar_Widgets class

    Using one code editor ( like NotePade++ ), open the functions.php file ( exists under your theme directory, e.g wp-content/your-theme/functions.php ).

    And then copy this code and paste into functions.php file :

    function overwrite_menubar_widgets_walker() {
        global $Menubar_Widgets_Plugin;
    
        remove_filter("wp_edit_nav_menu_walker", array( $Menubar_Widgets_Plugin, "register_menubar_widgets_walker"), 10 );
        add_filter("wp_edit_nav_menu_walker", array( $Menubar_Widgets_Plugin, "register_menubar_widgets_walker"), 500 );
    }
    add_action( 'after_theme_setup', 'overwrite_menubar_widgets_walker' , 200 );

    check the menubar-widgets section, if it had not effect, follow next step.

    3. Switch theme or disable another plugins

    You can switched back to twenty-twelve theme or disable another plugins, and then check the menubar-widgets section, if it had not effect, please report the issue here.

  17. eli_damon
    Member
    Posted 4 months ago #

    Changing screen options did it! Thanks. I hadn't even noticed those options before.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Menubar Widgets
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic