WordPress.org

Forums

Warning: implode() [function.implode]: (16 posts)

  1. mdcarlson144
    Member
    Posted 5 years ago #

    Update to 2.8 today via auto on admin. As I open pages to edit I get this warning at the top of edit page... e.g. )Warning: implode() [function.implode]: Invalid arguments passed in /home/content/f/o/r/forexsignalsgu/html/wp-includes/post.php on line 1762) how do I go about fixing this problem?
    Thanks... mdc

  2. Soprano
    Member
    Posted 5 years ago #

    I'm getting the same thing :S, I guess it has to do with one of the plugins we have installed not being compatible with 2.8...I have like 50 so no easy way to narrow it down and pinpoint the problem =(

    I cant edit the pages cause I get this error:

    Warning: implode() [function.implode]: Invalid arguments passed in /home/user/public_html/wp-includes/post.php on line 1762

    Warning: Cannot modify header information - headers already sent by (output started at /home/user/public_html/wp-includes/post.php:1762) in /home/user/public_html/wp-includes/pluggable.php on line 865

  3. claysound
    Member
    Posted 5 years ago #

    I am having the same problem here!!! how do we fix this!
    I have several sites going on this.

  4. Soprano
    Member
    Posted 5 years ago #

    @ claysound or mdcarlson144,

    Can any of you list the plugins you use to see if we share any similar ones?

  5. JasonGW
    Member
    Posted 5 years ago #

    I disabled DB-Cache and then refreshed the page, then re-enabled DB-Cache and the issue APPEARS to be gone.

    Oddly enough I still can't see my galleries when posted to a page though.

  6. crgo
    Member
    Posted 5 years ago #

    I use :

    I will make the list of plugins and then deactivate one by one and try it again.

    I will let you know,

    cr

  7. crgo
    Member
    Posted 5 years ago #

    BD Cache worked like a winner!!!!!

    I deactivated and reactivated it!

    that solved it I will continue to monitor and bring any concern about it!

    great!!

    thanks,

    cr

  8. lathaela
    Member
    Posted 5 years ago #

    New installation on three occasions but get the following when attempting to access "page".
    /homepages/32/d208110392/htdocs/"MyDomain"/wp-includes/post.php on line 1762
    No plugins installed.
    The two plugins "Hello Dolly & Akismet" removed.

    I have only been using WordPress for approx. 3 weeks; absolutly no problems with 2.7.1/MU.

    Where can I download 2.7.1 again?

    I have just done a clean reinstall, this time using 2.8.1 beta 2.
    When I log in and access "page" I received exactly the same error: -

    Warning: implode() [function.implode]: Invalid arguments passed in /homepages/32/d208110392/htdocs/LichfieldBlog/wp-includes/post.php on line 1762

    I have not altered anything after the install

  9. maritou
    Member
    Posted 5 years ago #

    Wow, I had this problem for a long time already and it's unbelievable it was THAT easy to be fixed! Crazy!

    Just deactivated and then reactivated the DB - Backup!

    Thanks!

  10. brettbum
    Member
    Posted 5 years ago #

    I'm using 2.8.4 and DB cache, unactivating db cache and re-activating makes the error page disappear at the top of the page while editing, but if I attempt to update the page i get the following error:

    Warning: implode() [function.implode]: Invalid arguments passed in /home/softdu5/public_html/wp-includes/post.php on line 1762
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/softdu5/public_html/wp-includes/post.php:1762) in /home/softdu5/public_html/wp-includes/pluggable.php on line 865
  11. brettbum
    Member
    Posted 5 years ago #

    tried un-enabling and un-activating db cache, still get the error even when it is no longer on, doesn't fix anything to turn it back on either.

  12. Japh
    Member
    Posted 5 years ago #

    I believe the solution is to disable DB-Cache, make your changes, and then re-enable DB-Cache.

    Having DB-Cache enabled seems to be what causes the problem. I've also noticed that having DB-Cache enabled prevents tags from saving to posts properly.

  13. brettbum
    Member
    Posted 5 years ago #

    I upgraded to WordPress 2.8.5, and I still have this problem regardless of whether or not I disable DB cache.

    This problem is seriously driving me nuts and won't go away.:(

  14. brettbum
    Member
    Posted 5 years ago #

    finally found a solution, is in Spanish and I had to use Google translate to understand it, but it definitely worked!

    http://wordpress-hacks.com/warning-implode-function-implode-invalid-arguments-passed-in-wp-includespost-php-on-line-1762.php

  15. sakthig
    Member
    Posted 5 years ago #

    I have encountered the same problem with my blog and i have solved the problem by deleting the extra file added in the wp-contents directory .

    Yes when i search my earlier backup i have found that , there will be two extra files added in the wp-contents directory named

    db.php and db.config

    I have just deleted the files and afterward it worked like a charm.

    Hope you works with you

  16. jeffqc
    Member
    Posted 5 years ago #

    ive this error with the new version :(

    Warning: file(/home/stripper/public_html/celebquebec.com/wp-content/home/stripper/public_html/celebquebec.com/wp-content/themes/metro_10/404.php) [function.file]: failed to open stream: No such file or directory in /home/stripper/public_html/celebquebec.com/wp-content/themes/metro_10/tools/post_templates.php on line 23

Topic Closed

This topic has been closed to new replies.

About this Topic