WordPress.org

Forums

Twitter Widget Pro
[resolved] Twitter Widget stopped updating (8 posts)

  1. Paxjah
    Member
    Posted 2 years ago #

    I've implemented this plugin on many sites, but I've had clients come to me in the past week with broken Twitter. They all ceased updating over a week ago. I've gone through the usual checks: deactivating plugins, deactivating themes, uninstalling, reinstalling, clearing update locks, authorising and reauthorizing APIs, and then completely deleting API and re-creating them. There is no reason why they should be broken.

    Please could you help? Send me a note and I will give you temp access to wp.

    http://wordpress.org/plugins/twitter-widget-pro/

  2. halftonemike
    Member
    Posted 2 years ago #

    I have the same problem with a client's site. After some troubleshooting I still haven't been able to fix it completely, but I do have a little more info to provide.

    In my case, I am using do_shortcode() to include the tweets on the front-page.php template. This shows only one tweet, even though I have the shortcode set to display 5, and the date for the tweet is July 16th. There is one more tweet on the 25th that is not showing.

    I have noticed that if I add the widget through the WordPress interface the tweets are displayed properly. If I need to, I can add a new widget area to my theme, but I would like to avoid this as possible.

  3. Paul Grant
    Member
    Posted 2 years ago #

    My tweets have also stopped updating. Considering moving to a new plugin very shortly.

  4. ryanoryan
    Member
    Posted 2 years ago #

    Same issue here. Plugin is no longer updating on my client sites.
    Has been down for nearly week. Any sign of a fix or even update on the issue?

  5. Paxjah
    Member
    Posted 2 years ago #

    I have started using http://wordpress.org/plugins/display-tweets-php/ and am very happy with the barebones plugin. I do hope the author of this Twitter widget will have a fix for this issue soon, but for now.. and quite possibly the future I am sticking with Display Tweets.

  6. square_eyes
    Member
    Posted 2 years ago #

    Same for me. I monitor 3 twitter accounts, all have been flaky over the last week for no reason. One in particular has stopped updating completely. Now I am told in the plugin settings that I ned to reauthorize. I've done that, but it does not stick.

  7. square_eyes
    Member
    Posted 2 years ago #

    Same for me. I monitor 3 twitter accounts, all have been flaky over the last week for no reason. One in particular has stopped updating completely. Now I am told in the plugin settings that I ned to reauthorize. I've done that, but it does not stick.

  8. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    The new version (2.6.0) did fix an issue that affected a couple specific versions of PHP (there was a bug in PHP that I had to work around). Other than that, the issue with a feed not updating is usually due to one of the following:

    1. Your account has hit it's API call limit. You can see your rate limit status by looking at the settings page (WP Admin->Settings->Twitter Widget Pro). Remember that all apps that you authenticate to your Twitter account are using your API calls, so they're not necessarily all being used by Twitter Widget Pro. Twitter Widget Pro actually uses only 20 calls per hour per distinct widget (a distinct widget is a widget with the same settings, so same username, number of tweets, etc).
    2. Your server is limiting loopback calls. This basically means that your server is keeping your site from calling itself. Whenever a user is visiting your site and Twitter Widget Pro determines that you need updates from Twitter, it actually calls another page on your site that does the update. This way the user doesn't have to wait while all the processing is being done. There have been some hosts that have turned off this functionality or blocked it with their firewalls. If this is the case, Twitter Widget Pro cannot update
    3. Some people have also had problems with some locks not clearing. There is a lock put in place to keep Twitter Widget Pro from trying to update the feed when it's already updating the feed in another process. There is a link on the settings page labelled "Clear Update Locks" that you could use to clear the locks and see if it helps.

    I haven't seen the issue where an account has unauthorized itself. I have several sites running the plugin and after checking each one still has all the original accounts authorized. Even my dev environment has accounts authorized from when I was first writing the authorization code. The only way to unauthorize an account is from Twitter (the API doesn't actually let you do that). You go to Twitter -> Settings -> Apps (https://twitter.com/settings/applications) and can revoke access there.

    If you're seeing a regular loss of connection that you can reproduce, I'd love to know the steps to reproduce it so I can look into it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Twitter Widget Pro
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.