WordPress.org

Forums

[resolved] Themes missing in Admin Panel (19 posts)

  1. dalkinn
    Member
    Posted 6 years ago #

    I'm new to wordpress, so I apologize in advance if this is a trivial question. I cannot get any new themes to show up in the admin panel. From everything I read, it's just a matter of putting them in /wp-content/themes/ and they should show up in the list under Design -> Themes. I only see the default and classic ones listed, not the three I downloaded.

    What am I missing here?

  2. dalkinn
    Member
    Posted 6 years ago #

    I should add that the new themes aren't double-directory listed. The style.css file is in /wp-content/themes/<theme>/

  3. mibsolutionsllc
    Member
    Posted 6 years ago #

    Make sure the contents of the theme are correct. Sometimes I've downloaded themes that didn't have the correct contents (bad link or something possibly on the website's part). If even one file is missing it won't show up in Dashboard.

    Also try downloading another new theme from a totally different site and see if this theme works.

    The above should help...

  4. dalkinn
    Member
    Posted 6 years ago #

    I downloaded two more themes from a different site. Still no new themes appear on the admin panel.

    Do you have a way to check the contents are correct? I have a hard time believing that five different themes have incorrect contents. This is making me crazy.

  5. iridiax
    Member
    Posted 6 years ago #

    What is your blog address?

  6. dalkinn
    Member
    Posted 6 years ago #

    http://www.davisondesigns.net

    Could there be something with permissions/ownership of the files? Does it matter who owns them?

  7. whooami
    Member
    Posted 6 years ago #

    theres nothing wrong with your permissions, or the ownership, as far as I can tell.

    http://www.davisondesigns.net/wp-content/themes/nutone/style.css

    make sure theyre all like that one.

    the index.php files throw blank pages but thats normal actually since calling that file directly is going to spit out an error, and this server obviously has error reporting turned off, which is a good thing, btw.

  8. dalkinn
    Member
    Posted 6 years ago #

    That nutone theme is one of the ones that doesn't work...

    I'm glad you told me it's good error reporting is off, since I wouldn't have known otherwise, heh.

  9. 5thward
    Member
    Posted 6 years ago #

    dalkinn...
    i too am having this problem... did you get it solved, if so, please share the solution! it's kind of frustrating.

  10. whooami
    Member
    Posted 6 years ago #

    5thward, you do not have the same problem, and Ive addressed your issue in your thread.

  11. dalkinn
    Member
    Posted 6 years ago #

    Anyone have any other ideas to try? For kicks I tried giving the themes full permissions (777) but that didn't do anything different. The two that wordpress comes with have limited permissions anyway, but I thought it was worth a try.

  12. dalkinn
    Member
    Posted 6 years ago #

    I don't think it matters, but I installed wordpress via yum, rather than the download. I might try deleting and installing via the download, but I don't see why it would matter.

    Anyone else have an idea? I see in the last few days there have been a few similar threads, but they were all unzipping/directory issues, not similar to mine.

  13. dalkinn
    Member
    Posted 6 years ago #

    Shameless bump :(

  14. dalkinn
    Member
    Posted 6 years ago #

    Okay, while I think everyone's given up on this, I did find a solution, though I'm not certain of the cause. I reinstalled with yum (doing a remove, deleting all my web files, then reinstall) and reset the databases just to find the same issue.

    After that, I deleted the web files again and downloaded the zip and installed that way. The themes showed up. As far as I know, the only difference between the two methods is that yum will locate the files in /usr/share which need to be copied, but the more notable difference is that the wp-config.php file is located in /etc/wordpress instead of the root web directory.

    After the themes were working, I decided to set up the symbolic link to the /etc/wordpress location again, but after doing so I lost all the additional themes in the panel. After I realized that broke theme selection, I returned it to its original condition. This still didn't fix it, so I just reinstalled the downloaded file one last time and I'll leave it as such.

    It leads me to suspect there's something with the symbolic link to the config file that is causing the issue, but it could be something with linux permissions, pathing, or even a bug. Removing the symbolic link should have fixed any of those issue if that were the case, so it could easily be something else causing the issue.

    I'm going to go ahead and tag this thread as resolved, but I do think that someone should look further into the difference between the yum installed and downloaded versions. I could find very little information on this site regarding yum installation, so perhaps it's unusual or atypical that WordPress would be installed that way. However, since it is possible, it would probably be worth mentioning, even if this is the only difference between the two.

  15. whooami
    Member
    Posted 6 years ago #

    the yum install of what?

    Im not finding any wordpress package in any yum repo.

    but I do think that someone should look further into the difference between the yum installed and downloaded versions.

    That said, if there is one, the responsibility for any package differences or install differences rests on the person or people that are maintaining the repo, not anyone here.

  16. dalkinn
    Member
    Posted 6 years ago #

    The yum install of wordpress. It's included on the Fedora Discs... certainly 9, but I think it was on 8 as well.

    That said, if there is one, the responsibility for any package differences or install differences rests on the person or people that are maintaining the repo, not anyone here.

    My comment was not really directed toward you or anyone in particular, but intended more as a caution for others that decide to install WordPress that way. There is also the small chance that the individuals responsible for that package might be around and read these forums.

  17. dumbusername
    Member
    Posted 6 years ago #

    I found the cause and the fix (with lots of help from dalkinn's notes above -- thanks dalkinn for posting your followup)

    I'm assuming the yum install is like the debian install which does something like this:

    The local wp-config.php file for the blog is a symlink to /etc/wordpress/wp-config.php which makes it easier to host multiple WP blogs on the same server. The contents of the /etc/wordpress/wp-config.php looks like this:

    require_once('/etc/wordpress/config-'.strtolower($_SERVER['HTTP_HOST']).'.php');
    define('ABSPATH', '/usr/share/wordpress/');
    require_once(ABSPATH.'wp-settings.php');

    The WP themes are not listed in the design gallery if they are not installed under the ABSPATH, but for that to work the ABSPATH also has to be same as the DocumentRoot path in the Apache conf of that host. So I edited the ABSPATH in /etc/wordpress/wp-config.php file like so:

    require_once('/etc/wordpress/config-'.strtolower($_SERVER['HTTP_HOST']).'.php');
    define('ABSPATH', '/var/www/'.strtolower($_SERVER['HTTP_HOST']).'/');
    require_once(ABSPATH.'wp-settings.php');

    ...and lo' behold the themes now appear in the design themes gallery.

    Note that for consistency sake I install each WP blog under /var/www/host.domain.com where "host.domain.com" is also the actual address of the blog as well as the name of its /etc/wordpress/config- file. This setup makes it easier to have multiple blogs on same server.

  18. RickBryan
    Member
    Posted 6 years ago #

    Thanks very much as well for this post; after a weekend of frustration, I was able to use dumbusername's wp-config file above to realize I had to modify my own wp-config file, which is not in any of the dozens of tutorials around the net on WordPress installations.

    Apparently, when you install WordPress using Synaptic, the wordpress directory is put under /usr/share instead of /var/www where all the tutorials and WordPress instructions say it should go. On my Hardy install, this caused an error message when the scripts in the /etc/wordpress/wp-config.php file were run. The /etc/wordpress/wp-config.php file was looking for wp-settings.php in the wrong place, and so by changing the line in the /etc/wordpress/wp-config.php to ('ABSPATH', '/usr/share/wordpress/');, I'm up and running.

    Of course you all knew that; this comment to help out others who may have a similar problem.

    Thanks again.

    Rick Bryan
    New York, NY

  19. dalkinn
    Member
    Posted 6 years ago #

    Indeed, thanks for the followup and solution had I proceeded along the way I did, dumbusername.

    With that, I now understand why it is set up the way it was, though I certainly wouldn't have guessed as such. On my server, I just run the one website/blog so the yum installation method just ended up complicating things. Next time I'll just download and unzip!

Topic Closed

This topic has been closed to new replies.

About this Topic