WordPress.org

Ready to get started?Download WordPress

Forums

MailPoet Newsletters
[resolved] styling the widget (5 posts)

  1. dekruyff
    Member
    Posted 1 year ago #

    Hi,

    Just downloaded and installed the plugin. When I place the widget on my site, the text and fields are aligned entirlely to the left. I want 20px padding, but where (Which css) do I edit that style?

    Thanks!
    Bas

    http://wordpress.org/plugins/wysija-newsletters/

  2. MailPoet Staff
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Bas, what's the link to your site?

    Since our forms have no styles, it's your own theme's styles that are affecting our forms.

    Let us know!

  3. dekruyff
    Member
    Posted 1 year ago #

    Currently the widget is disabled, so no use to share it is on http://www.anker-kompas.nl. I thought it was about the class "wysija-paragraph" which I cannot find anywhere defined. So I quote a snippet of the source of the page displayed when it has the widget on it.

    <div class="widget_foot"></div></li><li id="wysija-2" class="widget widget_wysija"><div class="widget_head"></div><h2 class="widgettitle">Onze nieuwsbrief ontvangen?</h2><div class="widget_wysija_cont"><div id="msg-form-wysija-2" class="wysija-msg ajax"></div><form id="form-wysija-2" method="post" action="#wysija" class="widget_wysija">
    
    Wil je op de hoogte blijven van onze activiteiten? Vul dan eenvoudig je naam en email-adres in. Circa vier keer per jaar sturen we je dan een nieuwsbrief.
    <p class="wysija-paragraph">
        <label>Voornaam</label>
        <input type="text" name="wysija[user][firstname]" class="wysija-input " title="Voornaam"  value="" />
    
        <span class="abs-req">
            <input type="text" name="wysija[user][abs][firstname]" class="wysija-input validated[abs][firstname]" value="" />
        </span>
    
    </p>
    <p class="wysija-paragraph">
        <label>Achternaam</label>
        <input type="text" name="wysija[user][lastname]" class="wysija-input " title="Achternaam"  value="" />
    
        <span class="abs-req">
            <input type="text" name="wysija[user][abs][lastname]" class="wysija-input validated[abs][lastname]" value="" />
        </span>
    
    </p>
    <p class="wysija-paragraph">
        <label>E-mail <span class="wysija-required">*</span></label>
        <input type="text" name="wysija[user][email]" class="wysija-input validate[required,custom[email]]" title="E-mail"  value="" />
    
        <span class="abs-req">
            <input type="text" name="wysija[user][abs][email]" class="wysija-input validated[abs][email]" value="" />
        </span>
    
    </p>
    <input class="wysija-submit wysija-submit-field" type="submit" value="Meld u aan!" />
    
        <input type="hidden" name="form_id" value="1" />
        <input type="hidden" name="action" value="save" />
        <input type="hidden" name="controller" value="subscribers" />
        <input type="hidden" value="1" name="wysija-page" />
    
            <input type="hidden" name="wysija[user_list][list_ids]" value="1" />
    
     </form>
  4. Tung Wysija
    Member
    Posted 1 year ago #

    Hi Bas,
    The snippet looks good for us.

    And as we mentioned previously, most likely, it's due to your theme style.
    Is it possible for you to enable the widget, so that we can sort it out for you?

    Otherwise, you should ask someone else who knows CSS. He/she definitely can resolve the issue.

    Hope this helps!

  5. MailPoet Staff
    Member
    Plugin Author

    Posted 1 year ago #

    Issue closed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags