WordPress.org

Ready to get started?Download WordPress

Forums

Still Caching (5 posts)

  1. diabolus
    Member
    Posted 7 years ago #

    i'm using WP Super Cache 0.5.1 on wp 2.3.1 !

    some minutes before installing this plugin, i post an article on my blog. after that, i activated this plugin, then i edit the post/article above, but the latest modification/edit of that post can't be appeared ONLY on main page, but on single page it can be appeared. another problem: Peter's Custom Anti-Spam plugin output cant' be displayed. and the last problem is the "edit" item on my blog still always appear ONLY on main page too, and NOT on single page, even i've log out from wp-admin/dashboard. perhaps its caused by the "Expiry Time" option? ... so please tell me which's the best setting of the "Expiry Time" option.

    another question, i see the different htaccess setting between on the WP Super Cache admin page and on the readme.txt file/http://wordpress.org/extend/plugins/wp-super-cache/installation/

    below the htaccess of Super Cache Compression option on my blog:

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1index.html.gz [L]

    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1index.html [L]

    # END WordPress

    ...what must i use?

  2. diabolus
    Member
    Posted 7 years ago #

    i am using the fancy permalinks. i'm forget, here the peter custom anti-sapm plugin output > http://img101.imageshack.us/img101/386/peterhh3.jpg

  3. Donncha O Caoimh
    Member
    Posted 7 years ago #

    Can you try disabling the anti spam plugin? perhaps that's causing the problem?

    It's quite likely that plugin won't work reliably anyway, especially if it doesn't use Javascript to create the image

  4. diabolus
    Member
    Posted 7 years ago #

    oke, i've disabled that plugin. so, what about that .htaccess

  5. Donncha O Caoimh
    Member
    Posted 7 years ago #

    What's in your .htaccess?

Topic Closed

This topic has been closed to new replies.

About this Topic