WordPress.org

Forums

ShortStat (17 posts)

  1. khackett
    Member
    Posted 10 years ago #

    Hi--

    http://katehackett.com/wordpress/shortstat/

    I ran the install, the trackme, put the code in the page (footer), and everything else. But what gives? It's blank?

  2. khackett
    Member
    Posted 10 years ago #

    I'm not sure why that doesn't take you to my blank shortstat page.

    http://katehackett.com/wordpress/shortstat/

    I cut & pasted, so if that doesn't work, my apologies.

    The tables are there but there's nothing IN the tables.

  3. khackett
    Member
    Posted 10 years ago #

    Yeah, link doesn't do what I want it to do. Sorry!

  4. khackett
    Member
    Posted 10 years ago #

    anybody?

  5. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Put the ShortStat tracking code at the very top of the index.php file in your /wordpress/ directory.

  6. khackett
    Member
    Posted 10 years ago #

    N.......ope, that didn't work....

  7. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Hm, it works for me. Your main index.php file should look like this:

    <?php @include_once($_SERVER["DOCUMENT_ROOT"]."/shortstat/inc.stats.php"); ?>
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    Where "/shortstat/" is the directory in which you have placed ShortStat's file.

  8. khackett
    Member
    Posted 10 years ago #

    Ugh, I wish you could see this. It's got all the tables but there's no data in them. It's just not registering visitors.

  9. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Does ShortStat display a red "Disabled" near the top?

  10. khackett
    Member
    Posted 10 years ago #

    Nope.

  11. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Contact ShortStat's developer.

  12. khackett
    Member
    Posted 10 years ago #

    Oh, goodie. He's unresponsive.
    I contacted him months ago.

  13. jennmiller
    Member
    Posted 10 years ago #

    In your ShortStat configuration file, did you change the logging from "false" to "true"?

  14. jalenack
    Member
    Posted 10 years ago #

    You said you tried trackme...but trackme should plant *one* entry to your database.

    I've had problems with shortstat in the past, but I've always gotten it up and running again.

    I put my shortstat tracking code in wp-blog-header.php, that worked fine

  15. khackett
    Member
    Posted 10 years ago #

    Yeah, there are NO entries.
    And this is what I changed:

    /******************************************************************************
    Tracking toggle

    The $shortstat variable turns this stats package on or off. This is used when
    updating from a previous version of ShortStat
    ******************************************************************************/
    $shortstat = true; // False is off
    ?>

  16. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Have you actually installed? ShortStat? Are the ShortStat tables in your database? What version of ShortStat are you trying to use?

  17. khackett
    Member
    Posted 10 years ago #

    I believe the tables are there. It said it's all installed.

    In fact, as I've stated, the tables are THERE, just nothing IN them.

    I'm using whatever the newest version is.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags