WordPress.org

Forums

RSS (29 posts)

  1. OldHickory
    Member
    Posted 8 years ago #

    I'm painfully new to WordPress. I've never worked with RSS or feeds, though I read the feeds page on the codex.

    I understand that WordPress automatically generates feeds, but I went to weblogs.com and entered my url, and got a message that there's no feeds. I clicked on the RSS icon on my template, and got a 'page not found'.

    If WordPress automatically generates pings or feeds or whatever, do I have to do anything other than update my page (create entries). If so, why wouldn't weblogs have been able to validate the feed? Also, I read some other feed topics on this forum, and tried going to my site's feed page (I forget the url but I followed the directions) and also got page not found.

    I checked the coding on the template and there's definitely a line in there about RSS feed, so as far as I know, the template isn't totally devoid of RSS (the feed codex says some templates don't have RSS included by default).

    I suspect I am missing something obvious, but I've never dealt with RSS in my life so I haven't a clue.

    Thanks.

  2. moshu
    Member
    Posted 8 years ago #

    1. Open the header.php file and remove the word "feed:" from the RSS links.
    2. Your feeds are OK, but not where you are looking for:
    http://www.hated-it.com/blog/feed
    - it has www
    - and has to point to your real location

  3. Jrexi
    Member
    Posted 8 years ago #

    I too and having problems with my RSS feed -- i am extremely new to RSS --

    I have the RSS buttons and links in my template, but when I click on them to set up a feed, I get the following error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/j4media/public_html/index.php:1) in /home/j4media/public_html/wp-commentsrss2.php on line 8

    Do I need to set something up first?

    Thanks in advance for your help.

    Jrexi

  4. moshu
    Member
    Posted 8 years ago #

    but when I click on them to set up a feed
    You don't have to "set up" anything. WP does it for you.

    For the error see the Codex:
    http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

  5. Jrexi
    Member
    Posted 8 years ago #

    Thanks moshu, I'll check out the error solution and see if that works for me.

  6. OldHickory
    Member
    Posted 8 years ago #

    You said:

    *1. Open the header.php file and remove the word "feed:" from the RSS links.
    2. Your feeds are OK, but not where you are looking for:
    http://www.hated-it.com/blog/feed
    - it has www
    - and has to point to your real location*

    Ok, so "feed:" appears twice in the header. Removing both instances will solve my issue without my doing anything else? Was this an error in the template code? I am confused by the second part about having to point to my real location.

    Thanks, by the way.

  7. moshu
    Member
    Posted 8 years ago #

    "feed" is a relatively new(?) protocol, not universally recognized by browsers. It is not an 'error' in the theme... let's say the theme author went ahead of the time :)

    2. Your WP installation is in a subfolder called "blog" while you display the site at the root level. You either didn't set this up correctly, or it just doesn't want to work, because
    http://www.yoursite.com/feed - does NOT work but
    http://www.yoursite.com/blog/feed - works!

  8. Jrexi
    Member
    Posted 8 years ago #

    OK, i found the following on the last 2 lines of wp-rss2.php:

    </channel>
    </rss>

    I removed those and still got the same error. The error mentions line 8 and here is what I currently have on line 8, do you see a problem there?

    header('Content-type: text/xml; charset=' . get_settings('blog_charset'), true);

    Maybe an extra space some where?

  9. OldHickory
    Member
    Posted 8 years ago #

    I suspect that's because the blog replaces my original index.html page - I installed WP via my host, which gave me the option to make the blog the home page, which I wanted to do.

    So, if the header code looks like this:

    ="feed:<?php bloginfo('rss2_url'); ?

    and
    ="feed:<?php bloginfo('comments_rss2_url'); ?>">Comments

    removing the two instances of the word 'feed' will get feeds working? It sounds like from what you said there should be more I have to do to make the feeds recognizable. Will readers always look in yoursite.com/feed (which evidently doesn't exist)?

    Sorry to keep this running, I'm just wary of changing the code and doing something improperly.

  10. moshu
    Member
    Posted 8 years ago #

    Jrexi,
    before messing with the code, please READ carefully the Codex link I posted. Till end. That's where it gives you clues how to read the error. You are looking at the wrong place...

  11. moshu
    Member
    Posted 8 years ago #

    OH,
    delete the "feed:" anyway.

    After that we'll be looking how to make the feedreaders to find the real location :)

  12. OldHickory
    Member
    Posted 8 years ago #

    I took them out, so the code now looks like:

    href="<?php bloginfo('rss2_url');

    and

    href="<?php bloginfo('comments_rss2_url');

  13. moshu
    Member
    Posted 8 years ago #

    Because of the WP_Cache I still see the "feed:" part.

  14. OldHickory
    Member
    Posted 8 years ago #

    I've noticed that sometime changes I make don't show up right away.

  15. Jrexi
    Member
    Posted 8 years ago #

    Ah, got it moshu...

    Thanks for leading me by the hand!

    Now I have to figure out how to get a page title in the browser head :)

  16. nevermore
    Member
    Posted 8 years ago #

    HI, I also know nothing of all this feed and code that is used. Today I went to Zoomclouds.com to get a tag cloud on my website..ok don't laugh....anyway I get a response from them that says..

    ERROR!: We could not process the data from this feed. It could be that the URL isn't pointing to a RSS/Atom feed, the server for the feed wasn't responding, or that something went wrong regardless. Please, verify your feed and try to update your cloud at a later time.

    So I went to my blog and tried the rss options..the rss 2.0 works and the comments rss2.0..but when I clicked on Valid rss I get an invalid page..does it have anything to do with the valid xhtml validator finding errors? I didn't realise I had to fix them..laziness...

    I have been here for hours going through the archives of these questions and half the time I don't understand what to do..thanks for any help

  17. moshu
    Member
    Posted 8 years ago #

    I don't know what you call the "browser's head" - if the top blue bar where it says "Mozilla Firefox"... WP does it (or your theme does it for you:
    http://j4media.com/?page_id=2
    displays: About >> yourblog >> your browser

  18. moshu
    Member
    Posted 8 years ago #

    OH, the WP-Cache plugin that is activated on your blog does exactly that: instaed of querying every time the database, it serves up "cached" pages. Do you have that many visitors you need that?
    Anyway, edit something on the blog, and it will show the changes.

  19. moshu
    Member
    Posted 8 years ago #

    @nevermore,

    don't hijack others' topic.
    Your feed's URL is this;
    http://leehane.ca/weblog/feed/

    and is valid:
    http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fleehane.ca%2Fweblog%2Ffeed%2F
    (read about how to eliminate even the warnings)

  20. OldHickory
    Member
    Posted 8 years ago #

    No, I doubt I need it. I'll disable it now.

    I still get an error/page not found when I click the RSS button on my page.

  21. moshu
    Member
    Posted 8 years ago #

    Seemingly, on your server this:
    http://hated-it.com/blog/feed/
    is NOT the same as
    http://www.hated-it.com/blog/feed/
    (I mentioned it earlier!)

    What are the two URI values in your admin > Options > General?

  22. OldHickory
    Member
    Posted 8 years ago #

  23. nevermore
    Member
    Posted 8 years ago #

    Moshu I apologise, I guess I didn't realise I was hijacking..now I see how I did that..was thinking it was same topic..sorry guys again..thanks for the help ..

  24. OldHickory
    Member
    Posted 8 years ago #

    I'm assuming both URIs reading "http://hated-it.com/blog" is part of, or the entire cause of, my feed problem. The feeds aren't where they are supposed to be, but I can't see where to fix it. I guess I need to either let the reader know where feeds are, or move everything to the place where the readers look, right?

  25. moshu
    Member
    Posted 8 years ago #

    I don't know, You still didn't disable the WP-Cache, so it's difficult to check the changes.
    I was waiting for that...

  26. OldHickory
    Member
    Posted 8 years ago #

    I did - I disabled the plug in as soon as you told me to.

  27. OldHickory
    Member
    Posted 8 years ago #

    It's definitely disbaled - I just checked (although when I checked the URI, I changed the blog description and that still hasn't updated, either).

  28. OldHickory
    Member
    Posted 8 years ago #

    Wow - I disabled the plug in but just saw that it was still working. I had to manually delete the cached pages and then delete the wp-config-cache file that was still there. It actually still said cache_enabled = true, well after I de-activated it!

    Anyway, the updates are working, as is the RSS button and weblogs.com says it's valid. How strange.

    Thanks for the help.

  29. moshu
    Member
    Posted 8 years ago #

    I assume it had the wrong files/content cached - and it served up that one whenever we tried to access it.
    I am glad it works now. Happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags