WordPress.org

Forums

Problems with WordPress/PHP5.0.1 (13 posts)

  1. langly
    Member
    Posted 10 years ago #

    Hi there..
    I tried to install WordPress on my Apache server, but it failed during the 3rd step, giving me this error:
    <b>Fatal error: Call to undefined function utf8_decode() in /var/www/weblog-test/wp-includes/functions-formatting.php on line 113</b>
    I don't quite understand why, since I'm running a clean nonmodified PHP version, the only thing not there is support for libxml, which should not kill the utf8 thing.
    My system is PHP5.0.1, Apache 2.0.50 running on my FreeBSD.5.1 box

  2. langly
    Member
    Posted 10 years ago #

    oh.
    I forgot to mention which version of wordpress I use..
    it's the nightly build, wordpress-2004-08-17

  3. TechGnome
    Moderator
    Posted 10 years ago #

    Which version of WP are you installing? I think (I might be wrong tho) that 1.2 (Mingus) has issues with PHP5, while the latest out of CVS (1.3 alpha) reportedly has resolved the PHP5 issues.
    TG

  4. TechGnome
    Moderator
    Posted 10 years ago #

    You posted the same time I did...... hmm.... not sure what the problem might be. A missing module perhapse, or there's something missing in the WP code (a danger of using the CVS). Since it's a nightly, it should be "good" code. No idea.
    TG

  5. langly
    Member
    Posted 10 years ago #

    here is the thing that bugs me about it..
    I've looked through the php-5 API, and it tells me that utf8_decode is a function that should be handled by PHP itself, and not by a faulty module in WP

  6. delsdog
    Member
    Posted 10 years ago #

    I get exactly the same error with WP1.2 mingus and php5.0.1 running on a windows xp box. Gonna try changing back to php4.x see if it helps

  7. davidchait
    Member
    Posted 10 years ago #

    did your PHP5 build for some reason not link in the expat/XML library? That'd likely cause this...
    -d

  8. delsdog
    Member
    Posted 10 years ago #

    don't know, how would I tell if it had or hadn't?

  9. carthik
    Member
    Posted 10 years ago #

    use phpinfo.php to find out details about the php install.

  10. TechGnome
    Moderator
    Posted 10 years ago #

    when I mentioned a missing module, I meant a missing Apache module. But it does look like it should be part of the PHP core..... ???
    TG

  11. realberen
    Member
    Posted 10 years ago #

    I just wanted to let you know, I have the exact same problem. PHP5 info can be found at http://217.116.80.30/info.php the system is Apache 2.0.50, PHP 5.0.1, FreeBSD 5.3Beta. I went for todays nightly after Mingus gave me the known install problems with stdObject

  12. Anonymous
    Unregistered
    Posted 10 years ago #

    �,��定了。�玩了。

  13. Anonymous
    Unregistered
    Posted 10 years ago #

    怎么那么多的ç?¨PHP写出æ?¥çš„BLOG程åº?都没问题,å??å??就让WP摊上这ç§?问题了?作者说ä¸?能登陆是PHP 5.0.0çš„BUG,既然知é?“是这个BUG造æˆ?,为啥ä¸?æ?¹è¿›ä¸€ä¸‹æœ‰é—®é¢˜çš„这几个æº?程åº??让WP在PHP 5.0以上的版本也能正常è¿?行?从æŸ?ç§?æ„?义上æ?¥è¯´é—®é¢˜è¿˜æ˜¯å‡ºåœ¨WP,因为别人写的是内核程åº?,是PHP语言的解释程åº?,WPå?ªæ˜¯ä¸Šé?¢çš„一个åº?ç?¨è€Œå·²ï¼Œåº?该是WP写的程åº?å°½é‡?è¿Žå?ˆPHP,而ä¸?是PHP为了你WP作æ?¹è¿›ã€‚所以我很å??对当WP在众多的ç?¨æˆ·å½“中出问题å?Žï¼Œä½œè€…ä¸?是想到如何æ?¹è¿›ä»£ç ?以适åº?PHP,而是在主页公布ä¸?是WP的问题,是PHPçš„BUG。我觉得这是一ç§?很弱智,很æ?žç¬‘çš„å?šæ³•ã€‚如果这个PHPçš„BUG一天ä¸?解决,以å‰?ç?¨äº†WPçš„ç?¨æˆ·å°±èˆ?弃PHP 5.0ä¸?ç?¨ï¼Œæˆ–者åƒ?有些人说的关掉Zend?我想大多数人是会选择æ?¾å¼ƒWP 而ä¸?是PHP 5.0或更高版本。

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.