WordPress.org

Forums

Annotum Base
[resolved] Problems using Javascript in posts (7 posts)

  1. solid7
    Member
    Posted 1 year ago #

    I am able to do simple things in the body of a post, like call alert boxes. But anything more complex than that fails. I have tried a plain HTML version on my webhost, calling the javascript, and it works fine. But in my Annotum theme posts, code doesn't work.

    Please help.

    Thank you.

  2. Carl Leubsdorf
    Member
    Posted 1 year ago #

    Can you put JavaScript in text widgets? The theme definitely strips script from articles, but it doesn't surprise me if this happens with ordinary posts as well.

  3. solid7
    Member
    Posted 1 year ago #

    How can I defeat that limitation?

    I'm not sure if I can use JS in widgets or not. Got something that I can test?

    Thanks for your reply.

  4. annotum
    Member
    Theme Author

    Posted 1 year ago #

    Can you try this?

    http://codex.wordpress.org/Using_Javascript#JavaScript_in_Posts

    I am pretty certain this will not work in articles, but it should work in posts.

  5. solid7
    Member
    Posted 1 year ago #

    Thanks, annotum. That was the very first thing I tried. No luck. :(

  6. solid7
    Member
    Posted 1 year ago #

    UPDATE: Got it all figured out. Calling externally is the ticket. There must have been some other error that I didn't pick up on before.

    Thank you for all of your help.

  7. annotum
    Member
    Theme Author

    Posted 1 year ago #

    Cool - glad it is working for you!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.