WordPress.org

Forums

WP Super Cache
500 errors in WP 3.0 (13 posts)

  1. JonRaasch
    Member
    Posted 4 years ago #

    Hi, after upgrading to WP 3.0 WP Super Cache is proving to be a performance issue on a couple of my builds. If I don't activate any other plugins I can get WP Super Cache to work, otherwise I start seeing 500 errors in various sections of my WordPress admin panel, and can't even activate WP Super Cache if too many other plugins are activated.

    I have a pretty high memory_limit set at 64MB, so I'm not sure if this is a known issue with WP Super Cache and WP 3.0.

    I haven't had a problem with WP Super Cache before 3.0, but would be very appreciative if anyone has any suggestions on this issue.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Could be the combination of all the plugins you use plus WP 3.0 requires more memory? Do the errors go away if you set the limit to 128MB? Each process won't use that much memory unless needed.

  3. JonRaasch
    Member
    Posted 4 years ago #

    I tried upping it to 128MB and still getting the 500 error when I try to activate it (and even at 256MB).

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    I don't know why you're getting those errors then. Sorry.

  5. JonRaasch
    Member
    Posted 4 years ago #

    Hey thanks for your help and for your work on this great plugin.

    I tracked down the issue to be related to my BS hosting company 1and1 who does really invasive htaccess stuff. Sorry to scapegoat WP Super Cache.

    For other 1and1 users, add this to the top of your .htaccess:

    AddType x-mapp-php5 .php

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Wow, that's obscure. Glad you figured it out. Hopefully someone else with the same problem will find the solution here in the future!

  7. nikola87
    Member
    Posted 4 years ago #

    I had the same problem and this is a solution! Great work JonRaasch, thanks :)

  8. jOt Creative
    Member
    Posted 4 years ago #

    Sadly, I have 500 server errors when I enable WP Super Cache as well, and I already had that line of code at the top of my .htaccess file. :(

    Of course, I don't have the errors on the backend at all; I only get it on the front end, and the whole site is down.

  9. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    drokkon - you're probably missing Apache modules required for the plugin to work, or some configuration is causing the error. Check your error log.

  10. Ryan Fitzer
    Member
    Posted 4 years ago #

    AddType x-mapp-php5 .php

    Yeah, unfortunately, that is the only way to get your 1and1 account to use php5. I found that out the hard way as well.

    Donncha, does WP Super Cache require php5? I looked over your plugin page but found nothing stating php5 as a requirement.

    If not then it's very obscure indeed. Maybe that .htaccess directive does some other things as well.

  11. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Supercache doesn't, but the CDN code might, and the Minify plugin I linked to before definitely does. WordPress itself will soon be moving to PHP5 so it's only a matter of time before you have to use PHP5.

  12. Ted-writer
    Member
    Posted 4 years ago #

    Thank you very much, JonRaasch!!!

    WP SuperCache error 500 1and1 problem
    is solved by adding

    AddType x-mapp-php5 .php
    at the beginning of .htaccess

    "1and1 problem" probably should be taken into a separate category. That's a tricky provider and a huge one.

  13. Brianemorgan
    Member
    Posted 4 years ago #

    Glad I found this! Thanks for the fix for a 1and1 wordpress hosted site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic