Widget Builder
[resolved] Cannot modify header information (3 posts)

  1. J.Frost
    Posted 3 years ago #

    Hello! I had a problem and I don't know how to solve it. Please help me.
    I think something with the php settings, because on another server it worked without any problems.

    It occurs when I try to add/change a widget:

    Notice: Undefined index: tribe_widget_builder_dashboard in /var/www/test/wp-content/plugins/widget-builder/classes/widget-builder.php on line 422

    Notice: Undefined index: tribe_widget_builder_disable_sidebar in /var/www/test/wp-content/plugins/widget-builder/classes/widget-builder.php on line 422

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/test/wp-content/plugins/widget-builder/classes/widget-builder.php:422) in /var/www/test/wp-includes/pluggable.php on line 881

    ps: 422 line in widget-builder.php:
    ${$f} = trim(strip_tags($_POST[$f]));


  2. J.Frost
    Posted 3 years ago #

    something with the php settings

    I'm sorry, of course it is not true =)

    define('WP_DEBUG', false); it solved the problem, but is it good decision?

  3. Timothy Wood
    Plugin Author

    Posted 3 years ago #

    I'm not sure I understand your follow up comment. Are you not defining WP_DEBUG in your wp-config.php file already? I'm not sure I understand what you asking if it is a good decision?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Widget Builder
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.