WordPress.org

Forums

podPress
Podpress Update Issues (14 posts)

  1. twinkleboi
    Member
    Posted 4 years ago #

    After updating to the latest version of podpress I have the following problems.

    In google chrome the 1 pixel out and podango players do not function, they open and close straight away.
    Although I select for the video previews to be hidden, they still appear and if I ask to hide them I lose the mp3 1pixelout players too.

    Please help!

  2. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    Thank you for your report!

    The option on the player settings page which hides the previews of the video players should work again (see podPress 8.8.5.1). When it is checked the preview player for video files will be invisible.

    Do you mean by "if I ask to hide them" that you tried to use the other option "Display Player/Preview"?
    If you are using this option all players (e.g. the mp3 players) and player preview will be invisible.

    There is another report about a not working 1pixelout player which shows the same behaviour as you have described it above.
    I have installed Google Chrome (5.0.375.99) on my Windows PC (XP SP3) and tried to play the last two episodes of your podcast and several other episodes on a different blog which uses podPress 8.8.5 and WP 3.0. But I could not reproduce this behaviour of the mp3 player. I could listen to the episodes without problems.
    I tried also with IE6, Opera 10.60, Safari 5.0 (7533.16) and of course FireFox 3.6.6. In all cases the last episode (TBS 576) played fine in the 1pixelout player.

  3. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    I'm sorry for the mix up. I meant that if the check box of the option "Display Player/Preview" has no cross or hook in it then all players and player previews will be invisible.

    Which is the Google Chrome version you are using? Which is the operating system on your computer? (Linux? Mac OS? Android?) Maybe the problem is related to the flash version which is installed on your computer/device. I'm using the latest version 10.1.53.64.

    Furthermore there is probably another issue with the new version of the 1pixelout player. While it is playing shows e.g. on your site only "Track #1" instead of the real ID3 data. But this is not everywhere same. I know a different blog with WP 3.0 and podPress 8.8.5 where the player shows the ID3 data. I'm still trying to find out the reason for this. It might have something to do with the new multi site blog feature of WP 3.0.
    Is your show one blog of such a multi site blog?

  4. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    The answer to my "Track #1"-observation is probably in the FAQ section of the 1PixelOut player which is also known as the WP Audio Player http://wpaudioplayer.com/frequently-asked-questions.

  5. twinkleboi
    Member
    Posted 4 years ago #

    The update sorted out the video preview problem -

    The 1pixelout/podango player is still not working, however if I choose to play in pop-out it works fine, confusing!

  6. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    The 1pixelout/podango player is still not working

    Does this problem occur only if you are using Chrome?

    Today, I tested with IE8 on a WinXP; IE9, Chrome and Firefox on Windows 7 and Iceweasel on an Debian Linux. In each case I could listen to your last episode without using the player in a popup window.

    So it seems to me that it might be somehow related to the operating system. Is yours a MacOS?

    BTW: A solution for the "Track #1" is going to be in the next version of podPress.

  7. twinkleboi
    Member
    Posted 4 years ago #

    I'm using Windows 7 with Google Chrome and yes it only happens in Google chrome, which I can't explain - the older plugin works fine on it as I've got podpress installed on other sites with the old version - I will ask others to check the player in chrome too :)

  8. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    podPress 8.8.5.2 contains besides some bug fixes and new 1PixelOut player options, some adjustments of the player object tag, which could eventually solve the problem with the not playing player.

  9. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    If 8.8.5.2 is still making the same trouble, please, download the current Development Version of podPress. This version is to find among the Other Versions.

  10. UncleWaldo
    Member
    Posted 4 years ago #

    Hi, currently using podpress 8.8.5.3 and I'm not getting a player. Both of the "hide player" buttons are unchecked. You can view at http://campgroundpirateradio.com

    Any suggestions?

  11. UncleWaldo
    Member
    Posted 4 years ago #

    oh, also the Play Now and Play in Popup links don't work.

  12. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    @UncleWaldo: You problem is not related to the problem which has been described in the earlier posts.

    In your case the cause for the not working resp. invisible player (and the other not working podPress elements) is that there are non of the necessary Javascript and style files of podPress included in the header section of your blog page(s).
    One probable reason for that is that your theme does not use the functions wp_head() or get_header() to load header information.
    (Calls of these functions are usually in the header.php or e.g. the index.php)

    Regards,
    Tim

  13. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    @UncleWaldo: I have looked into the headder.php of the Elegant Tonight theme and it is clear now. No wp_head() function call. It is not possible to use that theme and podPress together without adding the necessary code manually to the header.php file.
    Other plugins resp. widgets will not work with this theme either. Because of the missing wp_head() call.

    You could take an other theme or edit the e.g. the header.php file this way:

    old:

    </head>
    <!-- END html head -->

    new:

    <?php wp_head(); ?>
    </head>
    <!-- END html head -->

    (Add a new line and insert <?php wp_head(); ?>)

    Furthermore until the next podPress version, edit the style file (style.css), too.

    old:

    #content .post img {
    	border: 1px #282828 dotted;
    }

    new:

    /*
    #content .post img {
    	border: 1px #282828 dotted;
    }
    */

    (make comment characters around these lines)

    Before you start editing, please make a backup copy of the theme files.

  14. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    ... and edit the style.css in a different section (until the next podPress version):

    old:

    .noimage img {
    	display: none;
    }

    new:

    /*
    .noimage img {
    	display: none;
    }
    */

    The original line hides image which are in the post content e.g. on the main blog page. podPress uses an image as for the video player preview. If image are not allowed in the post section on the main blog page then the player preview would look strange and somehow not complete. The comment characters around these style lines fix this problem. But other picture in your post will be also visible on the front page.
    You could also disable the video player preview at the player settings page of podPress (e.g. if you like to hide the post content images on the main blog page).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic