WordPress.org

Forums

Instagram for WordPress
Log In Does Nothing? (22 posts)

  1. Hobo Audio
    Member
    Posted 2 years ago #

    after typing in my username and password, the wheel spins (as if logging in) and then clears out the date.

    nothing happens.

    anyone else? it worked yesterday?

    http://wordpress.org/extend/plugins/instagram-for-wordpress/

  2. _td
    Member
    Posted 2 years ago #

    I'm getting the same thing...I fill in my Instagram login info in the widget panel, click "Save" and then the login info disappears and I don't get the widget showing up in my sidebar...

  3. jbenders
    Member
    Plugin Author

    Posted 2 years ago #

    Hey guys,
    thanks for reaching out! Could you please check this again? There have been some issues with the Instagram API. If the issue persists, please let me know and I'll check.

    thanks,

    jbenders

  4. peterpan.glider
    Member
    Posted 2 years ago #

    Continue the same problem:

    "I'm getting the same thing...I fill in my Instagram login info in the widget panel, click "Save" and then the login info disappears and I don't get the widget showing up in my sidebar... "

    Thanks

  5. ubique48
    Member
    Posted 2 years ago #

    Same here:

    I installed this plugin today and am getting the same issue - widget will not retain my user/pass details, so cannot display images. Any suggestions or fixes?

    Thx.

  6. Label Brune
    Member
    Posted 2 years ago #

    Hello,
    I am WordPress version 3.3.1.
    I use Instagram for WordPress since 2 days, since yesterday I can not log in anymore. I find no solution (I remove and reinstall and remove from Instagram API)

    Thank you for your help

  7. rocomu8
    Member
    Posted 2 years ago #

    I'm having the same issue, after I input my login credentials it just goes back to blank and nothing happens.

    Anyone know why this issue says resolved?

    Thanks

  8. DaveE
    Member
    Posted 2 years ago #

    Hi all,

    I spent some time debugging this today and found that the API access (client_id and secret key) that the developer is using has started hitting Instagram's API authentication limit. The actual message returned from the API was "XAuth rate limit exceeded".

    Basically, the plugin has become popular enough that there are too many people trying to authenticate their Instagram credentials with the developer's API Client_ID.

    The simplest fix (all though certainly not the best as it requires hacking the plugin directly) is to get your own Instagram API credentials and replace the developer's with your own.

    You can do this by first getting a developer account and then registering a new application here: http://instagram.com/developer/.
    After that, replace the client_id and client_secret keys around line 194 of wpinstagram.php in the plugin's code.

    Again, this is a less-than-ideal solution, but or those of us in a hurry to get the login working again, this should do it.

    @jbenders, Maybe its worth adding a settings page to the plugin where you can help user get and enter their own API keys? Just thinking aloud about a long-term fix. I love the plugin. If you're interested, you can see how I used it over here: http://canalparkbrewery.com/

    Cheers!

  9. vus
    Member
    Posted 2 years ago #

    Hi DaveE

    Thanks for your quick fix tip. Until the plugin is back on track I would like to use your quick and dirty method, but I'm a bit confused about exactly what steps to take when signing up for the Instagram API. Any chance you would bother taking your time and guide us (me anyway :-D) a little further.

    Thx in advance.
    Vus

  10. looklab_dk
    Member
    Posted 2 years ago #

    Any news on the login problems - Tried DaveE's solution but it i still got the same error

  11. cfbauer
    Member
    Posted 2 years ago #

    Thanks DaveE!

  12. cfbauer
    Member
    Posted 2 years ago #

    This doesn't seem to be working for me. In the Instagram developer section I went to manage clients > register a new client, got the Client ID and Secret, and replaced theirs with mine in the plugin.

  13. Phil
    Member
    Posted 2 years ago #

    Same issue. Bummer.

  14. slabcobot
    Member
    Posted 2 years ago #

    Mine too. I tried the Dave E trick but it didn't work for me either.

  15. stevesinyard
    Member
    Posted 2 years ago #

    Same! I deactivated the plugin as it was seriously effected my website speed (loading time 14 seconds, with plugin deactivated loading time 2 seconds) now it won't let me log in when I redownloaded it. DaveE's way didnt work for me :(

  16. mlongman
    Member
    Posted 2 years ago #

    I finally gave up and went with this plugin.
    http://www.rollybueno.info/project/simply-instagram/

  17. slabcobot
    Member
    Posted 2 years ago #

    I did too on one site, sucks you can't have it be a slideshow though. Too much real estate showing all those pics.

    Also, Instagram for WordPress works on antother site that I haven't logged out of, but the new version has a link in the viewer to some crappy web viewer for instagram photos, you know... because the world needs another one of those.

    If you go back to the version before there is no linky.. i think it's 0.3.5

  18. khanov
    Member
    Posted 2 years ago #

    Why is this topic marked as "resolved"? Anyone got how to fix the login problem?

    after typing in my username and password, the wheel spins (as if logging in) and then clears out the date.
    nothing happens.

    Same. Tried to change client_id and client_secret keys as DaveE said, but it didn't solve the problem.

    Can anyone help?

  19. jbenders
    Member
    Plugin Author

    Posted 2 years ago #

    All,
    sorry for the latest issues and inconvenience I might have caused. @DaveE is correct: we're hitting Instagram's API authentication limit. Thanks a lot for the input and suggestions. I appreciate this very much.

    I have fixed the wordpress plugin to allow you to enter your own client information. This means you'll have to register a client so that you can use it without being limited by other users of the app.

    I need two more days to make this all nice and deploy it to wordpress. So by Sunday evening everything will be fine again.

    For the time being if things get urgent. You might wanna use this 'instagram gallery widget': http://ink361.com/#!/promote. Scroll down to the bottom off the page, specify how you would like it and click 'get code'. Then paste this code inside a widget box on your blog.

    Please stay tuned. When I have pushed everything to WordPress, I'll inform you all.

    Happy photo viewing!

    Jbenders

  20. jbenders
    Member
    Plugin Author

    Posted 2 years ago #

    Hi all,
    I just pushed another change to fix the authentication issue. It should be fine now.

    Please let me know if it works for you.

    Sorry for any inconvenience caused.

    jbenders

  21. sscriv
    Member
    Posted 2 years ago #

    once i updated the plugin - and added the client ID and client secret - i'm receiving this error. Any ideas?

    {"code": 400, "error_type": "OAuthException", "error_message": "Redirect URI does not match registered redirect URI"}

  22. jbenders
    Member
    Plugin Author

    Posted 2 years ago #

    DId you check the manual? It contains a probable redirect_url that can be used. It should end with authenticationhandler.php.

    You also have to make sure you are running 0.4.1, there was a bug in 0.4 that caused this error even if the settings were correct.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Instagram for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.