The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

FancyBox for WordPress
has_cap fix (5 posts)

  1. vonkanehoffen
    Posted 5 years ago #

    Just thought I'd post a fix for this:
    Change line 348 of fancybox.php to:
    $mfbfwadmin = add_submenu_page('options-general.php', 'Fancybox for WordPress Options', 'Fancybox for WP', 'edit_plugins', 'fancybox-for-wordpress', 'mfbfw_options_page');

    In debug mode, it was throwing an annoying "has_cap is depreciated" error, so I changed the "10" to "edit_plugins".
    Hope that helps someone!

    Thanks moskis for an excellent plugin :)


  2. Jose Pardilla
    Plugin Author

    Posted 5 years ago #

    Thanks for the fix, I'll implement it in next version.

  3. ChrisFo
    Posted 5 years ago #

    Nice Hotfix. I like to mention another WordPress 3.1 debugging mode & FB-WP 2.7.5 notice in my FRONTEND (Twenty Ten 1.2):
    Undefined variable: loadAtFooter in /wp-content/plugins/fancybox-for-wordpress/fancybox.php on line 199

    I'm not a PHP-Coder, so I don't risk to post some maybe false code of mine here.

  4. juandavidhern
    Posted 5 years ago #

    I did the same and it's showin the same notice 'Undefined variable: loadAtFooter in /'
    any suggestion?

  5. flick
    Posted 5 years ago #

    @juandavidhern: Once I checked the 'Footer' checkbox in the settings, the undefined variable error disappeared.

    I still get the has_cap error though, but I assume this is because a new version was never released?

    @vonkanehoffen: Thanks for the fix! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • FancyBox for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic