Yoast SEO
Plugin auto-disables date-based archives! (5 posts)

  1. Niramaya
    Posted 3 years ago #

    Hello - Have had Yoast activated for some time and just noticed that trying to access date archives redirects to blog homepage. I made sure that in "Date Archive" settings, "Disable the date-based archives" is NOT checked/enabled. What could be causing this? I know for certain it's yoast as I de/re-activated all plugins and it's the culprit :(

    Pls advise!


  2. Niramaya
    Posted 3 years ago #

    Update: Have tried deactivating plugin, flushing W3TC & browse cache + activating.. same results.

  3. Niramaya
    Posted 3 years ago #

    Would anyone advise that I delete the plugin entirely and start over? Really hoping to get some pointers. Have searched forums over and over and nothing seems to fix this issue. Thanks again!

  4. Niramaya
    Posted 3 years ago #

    Still no luck over here. Beginning to think finding a workaround/solution is not possible. Hate the prospect of having to deactivate/uninstall :(

  5. oxfordian3
    Posted 2 years ago #

    I had this problem, even with the latest version of WP SEO (1.4.15).

    The "Disable the date-based archives" checkbox was on, and I turned it off, but the archives continue to get redirected to the home page.

    I put in some debug code, checking the value of:

    isset( $options['disable-date'] ) && $options['disable-date']

    and it reported that disable-date was still On.

    I never found out how the option value could return On when the checkbox was Off, but in the end I just disabled archive_redirect, by putting the following in my theme's functions.php:

    function my_plugins_loaded() {
    	global $wpseo_front;
    	remove_action( 'wp', array( $wpseo_front, 'archive_redirect' ), 1 );

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic