WordPress.org

Forums

NextGEN Gallery
[resolved] NG 2.0.0: ImageBrowser instead the effect?? (19 posts)

  1. roger995
    Member
    Posted 1 year ago #

    hi,

    Just updated to WP 3.6 and NextGen 2.0.0. Things are basically working.

    How does one duplicate the old 'Gallery' setting:
    "Show ImageBrowser: The gallery will open the ImageBrowser instead the effect."

    Spent a bunch of time on this, with no luck.

    thanks!

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @roger995: You are wanting it so that if you click on a thumbnail in a thumbnail gallery, the thumb opens/reloads the gallery using imagebrowser rather than a lightbox?

  3. roger995
    Member
    Posted 1 year ago #

    @photocrati
    yep, exactly.

  4. roger995
    Member
    Posted 1 year ago #

    hi,

    I guess the issue is that there isn't a way to apply the imagebrowser (instead of an effect) to a gallery using 'NextGen Basic Thumnails'.

    I see that I can now choose 'no lightbox' in lightbox effects area. Is there some code one can insert into the associated 'code' field to get the imagebrowser to kick in there?

    thanks!
    r

  5. Jeroen
    Member
    Posted 1 year ago #

    This is something that is also interesting to me.

  6. Rich G
    Member
    Posted 1 year ago #

    Me too...

    I'm unable to upgrade to the latest version now that the 'Show ImageBrowser' has been removed. :(

    The overlays aren't very friendly with the responsive design of the website.

  7. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Hey all - just wanted to follow up. This is one of the small handful of things that we just didn't translate into 2.0. So we need to add it back in. It's on our issue list right now and relatively high priority. For now, you'd need to use continue using Lightbox Effects rather than the imagebrowser gallery type.

    My apologies for having missed this one. (Erick)

  8. Jeroen
    Member
    Posted 1 year ago #

    Thanks for the feedback on this Erick.

  9. Rich G
    Member
    Posted 1 year ago #

    Indeed - thanks for the feedback and support.

  10. carlymyman
    Member
    Posted 1 year ago #

    Hi -
    2.0 is looking great! Thanks!

    I did also want to weigh in on this request as I am also in desperate need of the ImageBrowser gallery functionality.

    Thank you so much for making it a priority. Cant't wait!

  11. Jeroen
    Member
    Posted 1 year ago #

    @photocrati, could it be that using a setup like this would solve the SEO problem that I have with just the imagebrowser, as I've described here? http://wordpress.org/support/topic/problem-indexing-photos-with-image-browser

  12. Blindenschule
    Member
    Posted 1 year ago #

    @photocrati

    In what version can we expect the update? Can you tell us an approximate date?

  13. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @Blindenschule - We do not currently have a timeline specifically in place for this item but feel free to watch our latest beta page for upcoming features, fixes and other items here: http://www.nextgen-gallery.com/nextgen-gallery-latest-beta/

    @Jeroen - We are still working on "WordPress SEO by Yoast" related issues please bear with us.

    Thanks!

    - Cais.

  14. rosebean
    Member
    Posted 1 year ago #

    Would love to have this feature back as well. I am stuck using the old version until then. As far as I can tell this hasn't been fixed in the current version.

  15. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @rosebean - The option to use the ImageBrowser for Thumbnail Galleries rather than a Lightbox Effect was added a few versions ago ... and is seeing some enhancements/corrections in the next release we are preparing for this week.

    - Cais.

    Also to note: @carlymyman, @Jeroen, and @Blindenschule ...

  16. rosebean
    Member
    Posted 1 year ago #

    I figured out how to get the ImageBrowser to display after a thumbnail is clicked on. Unfortunately now I can't figure out to edit the ImageBrowser template. I found the instructions on how to create a template for the gallery.php but not imagebrowser.php. Any help?

  17. roger995
    Member
    Posted 1 year ago #

    @photocrati - Yes, saw the ImageBrowser feature recently. Works beautifully. Thanks!!

  18. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @roger995 - Thanks, we found some rather unique issues with it and will be including fixes for those with the next update as well.

    - Cais.

  19. roger995
    Member
    Posted 1 year ago #

    hi again,

    Just successfully upgraded NextGen to 2.0.40 on the site using the imagebrowser over which I initially started this thread. Everything is working with one substantial glitch. My custom 'nggallery.css' stylesheet keeps getting over-ridden by the default imagebrowser stylesheet. If I reload the browser, then the custom style sheet is properly referenced. But randomly(?), the image browser stylesheet takes over again when navigating through images. It behaves the same whether I'm using legacy shortcode or the current gallery code.

    Stylesheet here:
    /wp-content/ngg_styles/nggallery.css
    Was able to select in NextGen settings.

    Customized template here:
    /wp-content/themes/[my_child_theme]/nggallery/imagebrowser.php
    Was able to select in NextGen image browser settings.

    When I disable this file everything works perfectly:
    plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_imagebrowser/static/style.css

    I suppose another consideration is that my custom imagebrowser template is the one I used with pre 2.x NextGen.

    thanks again
    r

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic