WordPress.org

Forums

[resolved] [closed] multisite on WP 3.2.1 not working (17 posts)

  1. michalfanta
    Member
    Posted 3 years ago #

    I've been searching google and this forum all day and cannot find an answer. I would like to start using multisite on my wordpress 3.2.1, but when I add the code mentioned in the instruction manual here in wordpress documents, to the wp-config file and upload it to the server, no "network" link appears under the tools menu. I have no idea how to resolve it.
    Could you please help me with that?
    Thank you very much.

    Michal

  2. What code are you adding?

  3. define('WP_ALLOW_MULTISITE', true);

    that should be the only line you add, and it should NOT be at the bottom of the file. also, if you are copy/pasting n Windows, make sure the quotes aren't curly, but straight like '.

  4. michalfanta
    Member
    Posted 3 years ago #

    I am adding the code Andrea_r mentioned over the text recommended in the CODEX manual like this (under the DEBUG, over the That's all...):

    define('WP_DEBUG', false);
    
    define('WP_ALLOW_MULTISITE', true);
    
    /* That's all, stop editing! Happy blogging. */

    I use a mac so I hope the curly quotes shouldn't be a problem.
    I tried to paste it there again - just in case - but still no change.

    Michal

  5. Angela
    Member
    Posted 3 years ago #

    Just a reminder, after you placed that code, you should be looking for the 'network admin' menu under your own name (After clicking on it to expand the hidden menu) on the upper right corner, not under 'Tools' menu. Hope this helps.

    Regards,
    Angela

  6. michalfanta
    Member
    Posted 3 years ago #

    Do you mean the "Howdy, Michal" in the upper right corner which expands the options to view my profile and sign out?
    If so, I checked and unfortunately there's nothing there either. :(
    Thank you Angela.

    Michal

  7. Angela - that only appears after the network is completely set up. He needs to look under Tools -> Network setup *first*.

    Michal - what host are you on?

    I am adding the code Andrea_r mentioned over the text recommended in the CODEX manual

    Mine is not different. I copy/pasted from the codex page.

  8. michalfanta
    Member
    Posted 3 years ago #

    I am using a hosting from http://www.forpsi.com - a shared linux hosting with PHP 5.3 and database version: 5.1.41. They also prepared a subdomain with me on the apache server.
    I hope it helps.

    Michal

  9. jonhjonh3000
    Member
    Posted 3 years ago #

    not sure if it is quite related, but the automatic update from 3.1.3, with multi-site acivated, does not work.
    Still looking for a solution.

    Cheers
    Jonh

  10. jonhjonh3000
    Member
    Posted 3 years ago #

    not sure if it is quite related, but the automatic update from 3.1.3, with multi-site acivated, does not work.
    Still looking for a solution.

    Cheers
    Jonh

    I should be more precise:
    even after deactivating all plugins, and trying to up the memory limit in .htaccess and wp-config, I still get the following error: "Fatal error: Out of memory (allocated 30670848) (tried to allocate 4580905 bytes) in /homepages/[...]/wp-includes/class-http.php on line 1426"

  11. jonhjonh3000 - Not related as much as you'd think, make a NEW topic for yourself. Though likely your server just doesn't have the memory for the full auto-upgrade, do it manually. As of 3.2, the upgrades are incremental and, thus, smaller.

  12. @Michal and they'l let you enable multisite? a couple hosts don't.

    you do not need specific subdmains made, it uses wildcard subdomains

  13. ctocusn
    Member
    Posted 3 years ago #

    @michal - Just a thought - make sure you're using a text editor and NOT a word processor that might be throwing in formating or special characters.

  14. michalfanta
    Member
    Posted 3 years ago #

    Thank you everyone for your help, everything works now. It is quite embarrassing to admit, but I was editing the wp-config file on my backup ftp server and not on the one currently running my website. I am deeply sorry for waisting your time.

    Thank you again.
    Kind Regards,

    Michal

  15. marguello
    Member
    Posted 3 years ago #

    need help here.. urgent. i installed wordpress 3.2.1 all works fine. for the wpms i added the code as per CODEX, i saw network setup tab i configure it, i had some trouble in this area but pull through it i'm using sub domain i'm using 000webhost free hosting, after configuring all i relogin and now have access to network admin where it says howdy Max, so i enter there click add new site, it says site added successfully my main domain is wpms.site50.net so i add the new site gch.wpms.site50.net, i try accessing and i get this error as not found http://error404.000webhost.com/?

    i thought i should've selected sub-directory, if then how can i remove this settings to start all over again deleting the wordpress?
    what did i do wrong and how do i fix it? thanks.

  16. pearlz
    Member
    Posted 3 years ago #

    go to your cpanel on 000webhost and click add on domains.....add your new domain....then istall WP in the FTP for your new domain.

  17. marguello - This post is marked resolved. Please make your OWN post next time (or if Pearlz's directions don't help).

Topic Closed

This topic has been closed to new replies.

About this Topic