WordPress.org

Forums

Multi Site issue (13 posts)

  1. achoke
    Member
    Posted 5 years ago #

    I recently upgraded my WordPress installation to 3.0

    I then followed this screencast. I was able to create the .htaccess file, and also update wp-config with the needed information.

    I then created a "blogs" folder within the wp-content directory.

    I was able to create a site via the main administration, however when I try to visit this site I get a 404 error.

    I then looked in the blogs folder and there is no content in there?

    Can anyone be of assistance??

    MUCH APPRECIATED AND THANKS IN ADVANCE!!

  2. I then created a "blogs" folder within the wp-content directory.

    It has to be called blogs.dir, not just blogs. The blogs do not live there, they are vortual. Yes, even subfolder blogs.

    If you're getting a 404, I mentioned this in the forum sticky, as well in numerous posts.

    It;s your htaccess file - either you didn't get it in there right, the file is not being read, mod_rewrite is not enabled or not reading the file.

  3. riversatile
    Member
    Posted 5 years ago #

    Hi Andrea,

    I've the same problem.

    Main WordPress install : http://www.riversatile.fr
    Second site : http://series.riversatile.fr

    Ihave created "blogs.dir" Directory in http://www.riversatile.fr/wp-content/.

    When I try to reach http://series.riversatile.fr, I see the empty page with "Index of /" there is no file.
    When I try to reach Dashboard at http://series.riversatile.fr/wp-admin/, it returns 404 Error :
    Not Found, The requested URL /wp-admin was not found on this server.

    I've the conviction there is a problem with REWRITEor .HTACCESS or WP-CONFIG

    Could you help me ?

    Here is my .HTACCESS file :

    # Workaround for 'Google XML Sitemap' Plugin compatibility in WP 3.0.1 (MU)
    RewriteRule ^sitemap.xml sitemap-%{SERVER_NAME}.xml [L]
    RewriteRule ^sitemap.xml.gz sitemap-%{SERVER_NAME}.xml.gz [L]
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
    
    Order allow,deny
    allow from all
    
    <Files .htaccess>
    order deny,allow
    deny from all
    </Files>
    <files wp-config.php>
      Order deny,allow
      deny from all
    </files>
    <files wp-settings.php>
      Order deny,allow
      deny from all
    </files>

    Here is the important part of my WP-CONFIG file :

    /** Activer l'option permettant de basculer WordPress en mode Multi-Sites. */
    define ('WP_ALLOW_MULTISITE', true  ) ;
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.riversatile.fr' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* C'est tout, ne touchez pas à ce qui suit ! Bon blogging ! */
    
    /** Chemin absolu vers le dossier de WordPress. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Réglage des variables de WordPress et de ses fichiers inclus. */
    require_once(ABSPATH . 'wp-settings.php');
  4. When I try to reach http://series.riversatile.fr, I see the empty page with "Index of /" there is no file.
    When I try to reach Dashboard at http://series.riversatile.fr/wp-admin/, it returns 404 Error :
    Not Found, The requested URL /wp-admin was not found on this server.

    I've the conviction there is a problem with REWRITEor .HTACCESS or WP-CONFIG

    It;s not the config or the htaccess file. You have subdomain blogs. you need to set up wildcard subdomains both in Apache and your DNS records. If you do not know how to do that, ask your web host. chances are they have to set up the Apache side, if they even allow it.

  5. fxbenard
    Member
    Posted 4 years ago #

    Did you fix your problem, i have the same one but i'm using xampp.
    how can i do setup the wildcard subdomains.
    Thanks

  6. You cannot set wildcard subdomains locally on your computer.

  7. fxbenard
    Member
    Posted 4 years ago #

    Is there another way to make my wordpress multisite to work locally.
    I followed the instructions find in the codex, every works fine until i try to acces the admin of the second site... big error localhost 404

    Thanks

  8. Set up the subdomain manually in your hosts file.

  9. tfunsten
    Member
    Posted 4 years ago #

    I had the same problem setting up wordpress multisite locally on XAMPP (using subfolder style). I checked the database with phpmyadmin to see if the new entries had been made, and guessed it was a mod_rewrite problem. I reinstalled wordpress on XAMPP and made sure mod_rewrite was enabled in httpd.conf, and that I had made changes to the correct .htaccess file. After that it worked.

  10. fxbenard
    Member
    Posted 4 years ago #

    Thanks for the advice but i checked already when i create a subdomain in my database and the datas are created.
    I think i just don't know how to put my subdomain in my host files
    127.0.0.1 localhost is okay but i don't know what to put if my maindomain is http//localhost/mymbeautifulsites and my subdomain is http//localhost/mybeautifulsites/dev
    Do i have to change something in my http host files and what ?

    thanks you and sorry to be such a noob with that. I want it so much to work.

  11. If your blog address is just http//localhost/ then you cannot use subdomain, because the address woudl be http//subdomain.localhost/ and would just not work right.

    WordPress does not create nor does it need a folder on the server (or your computer) for the extra blogs. They are virtual.

    If you just want to play around, make it a subfolder install.

  12. hoangquang
    Member
    Posted 4 years ago #

    Oops, I've got the same problem! Anyone can help us?

  13. fxbenard
    Member
    Posted 4 years ago #

    I finally fixed my problem by making a brand new install of my wp database and of wordpress with a subfolder and magic, everything is working
    thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.