WordPress.org

Forums

Easy Image Gallery
Lightbox Not Working (9 posts)

  1. rahulkhosla
    Member
    Posted 1 year ago #

    Please take a look:
    http://development.pointquack.com/?page_id=52

    The lightbox is set to prettyPhoto, and when I click on an image, it just loads to the original image, no lightbox.

    Thanks

    https://wordpress.org/plugins/easy-image-gallery/

  2. rahulkhosla
    Member
    Posted 1 year ago #

    Also i tried fancybox. Still not working, using Google Chrome.

  3. Andrew Munro (sumobi)
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Your site has 2 Javascript errors on it. See:
    https://cloudup.com/cgb1LkJ_S2V

    When you have JS errors it breaks all other JS such as the lightboxes used by Easy Image Gallery. Once you fix your site, Easy Image Gallery will work just fine.

  4. kellyalan
    Member
    Posted 11 months ago #

    Same with me -- the lightbox effect isn't working -

    http://fittennis.net/camp-photos-2012

    not sure how to use cloudup >> is it a web site testing system?

  5. Andrew Munro (sumobi)
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Kellyalan,

    No, Cloudup is a service to share screenshots and files. You also have a Javascript error on your website caused by a file called gprofiles.js. The lightbox, and any other JS functionality will fail when you have an error.

    https://cloudup.com/cZvrGHJc_TA

  6. koyaanisqatsi80
    Member
    Posted 9 months ago #

    Hi, I have tahe same problem. Can you check my page ?
    http://test03.gummydesign.it/references/

    When I click on the thumbnail the image open in new window, not in lighbox.

    Can you help me please?

  7. Andrew Munro (sumobi)
    Member
    Plugin Author

    Posted 9 months ago #

    If you switch themes temporarily, does it now work? try also deactivating other plugins to find the source of the issue. Let me know how you go.

  8. kellyalan
    Member
    Posted 9 months ago #

    I can't believe I never got back to this ..

    how did you locate the Javascript error / I'm looking in my FTP files and can't locate a file called gprofiles.js

    Thx

  9. Andrew Munro (sumobi)
    Member
    Plugin Author

    Posted 9 months ago #

    These files are causing the issues. Sometimes it's only really the first one that's causing the second one:

    http://fittennis.net/wp-includes/js/thickbox/thickbox.js?ver=3.9.2
    http://s.gravatar.com/js/gprofiles.js?ver=2014Augaa

    Do you have another gallery plugin active?
    Do you have Jetpack?

    Try disabling all your other plugins except Easy Image Gallery and see if it resolves the issue. Then activate each plugin one by one until it stops working again. Then you'll find the culprit. Also try temporarily switching themes to 2013/2014 to rule out a theme issue.

    Here's how you view JS errors, open up your browser's developer console:
    https://cloudup.com/c4kjCpZwcSe

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Easy Image Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic