WordPress.org

Forums

Installing Multisites Issue (6 posts)

  1. ksajdak
    Member
    Posted 1 year ago #

    Installed WordPress for a MultiSite install and things are only partially working.

    Set up the directory and the install is now complete.

    The "first" site works fine.

    The first "New" site is there, but I cannot access the site admin . .
    (Two reasons I want to are to change the Theme and to see if I can configure the site to it's own database.)

    When I click on the "Dashboard" for the new site, I get the following "Firefox" error:

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    This problem can sometimes be caused by disabling or refusing to accept cookies.

    Google Chrome says:

    This webpage has a redirect loop

  2. ksajdak
    Member
    Posted 1 year ago #

    Additional update . . .

    Uninstall, reinstalled. Same error.

    Here's the code from my web/config file:

    <system.webServer>
            <rewrite>
                <rules>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^wp/([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                    </rule>
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^wp/([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="wp/{R:1}" />
                    </rule>
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="^wp/([_0-9a-zA-Z-]+/)?([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="wp/{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>

    And from my wp-config file:

    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'sportsage.net');
    define('PATH_CURRENT_SITE', '/wp/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */

    Help?

  3. ksajdak
    Member
    Posted 1 year ago #

    Let me add . . .

    My directory structure is

    root
    . . wp (Contains 1st site)
    . . . . carroll (second site)

    When I try to access the Dashboard for the second site (first one works as advertised) I get the error messages.

    If I go to view the site, it looks like a bad mobile site with little formatting.

    If I try to add a post . . . I get a "Not Found" message on the unformatted page display.

  4. seekerjon
    Member
    Posted 1 year ago #

    I had exactly the same problem.

    Following the instructions for setting up a multisite network I also copied those lines to my wp-config file and to my .htaccess file I copied:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wp/index.php [L]
    </IfModule>

    Since I had another multisite installation in another domain, I looked at that .htaccess and found different lines:

    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    When I replaced the first set of lines with the second, everything worked.

  5. ksajdak
    Member
    Posted 1 year ago #

    Thanks,

    Added this code to .htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>

    No luck.

  6. Please use the CODE tags (see the button on the bar above the text entry box?). It makes things readable.

    If you have a web/config file, you don't use .htaccess.

    Are you using nginx or IIS?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.