WordPress.org

Forums

http to https general settings problem (7 posts)

  1. delosbueis
    Member
    Posted 3 years ago #

    hello

    I wanted to change my blog from http to secure https and so I installed the wordpress-https plug in.
    Then I changed the http to https://mydomain.com/myblog as my URL and homepage in the blog’s general settings.
 Now I cannot log in to my wp-admin.

    It says “Safari can’t open the page “https://mydomain.com/myblog/wp-login.php” because Safari can’t establish a secure connection to the server “mydomain.com”.
    if I type http://mydomain.com, it shows the blog but the layout is messed up, and if I click on any of the pages it goes back to https and same message as before.
    I tried deleting the wordpress-https plug in and adding “define('WPHTTPS_RESET', true);” to my wp-config.php file but it still goes back to https and same message when I click on any page.

    I realized I have messed up trying to do this without researching it first and I am lost now. I have searched for a solution on the forum but no joy.

    I saw “you need to make sure that you have your own SSL certificate installed on your domain” - I don’t know if I have this and I guess this has something to do with it.

    For now I would just like to go back to the previous stage of my blog on normal http and be able to work on it. I guess I need to change those general settings back but I don’t know how as I cannot log in and I didn’t see anything on the options-general.php or the theme’s functions.php or the .htaccess.

    Please help!!!! Thanks!

    yolanda

  2. fonglh
    Member
    Posted 3 years ago #

    Follow the instructions on the page below to change the URL settings back.
    http://codex.wordpress.org/Changing_The_Site_URL

  3. delosbueis
    Member
    Posted 3 years ago #

    fonglh - thanks a million!!!! problem solved!!
    if it's not too much to ask, what's the best and safest and less painful way to make the site https please?
    thanks!

  4. fonglh
    Member
    Posted 3 years ago #

    I'm not sure about the details but you will definitely need your own SSL cert. Ask your hosts about how to get one.

  5. djmic
    Member
    Posted 3 years ago #

    For anyone else with this issue, my host (BlueHost) was able to reset my URL and homepage back to http from https with a 60 second phone call.

  6. delosbueis
    Member
    Posted 3 years ago #

    thanks fonglh again! I will check with my host :)

  7. danihowto
    Member
    Posted 2 years ago #

    i used the Edit functions.php method and it works great
    http://www.myblogtricks.com
    http://www.danihowto.com

Topic Closed

This topic has been closed to new replies.

About this Topic