WordPress.org

Forums

Advance WP Query Search Filter
Doesn't work (5 posts)

  1. kraket3
    Member
    Posted 1 year ago #

    I don't know what I'm doing wrong but it doesn't work at all for me. I've tried adding custom meta and just using categories but no matter which options I specify I get no search results.

    Any ideas?

    http://wordpress.org/plugins/advance-wp-query-search-filter/

  2. TC.K
    Member
    Plugin Author

    Posted 1 year ago #

    Can't tell what is the problem from your question. There are so many causes.

    Possibilities:
    1. You posts don't have the custom meta and taxonomy that you created in search form.
    2. Wrong post type choose.
    3. Plugin conflict.

  3. kraket3
    Member
    Posted 1 year ago #

    It was indeed a plugin conflict, specifically the search plugin Relevanssi. I guess I'll look for another alternative for post sorting because Advance WP Query Search Filter has some great features I wanna keep.

  4. mike022
    Member
    Posted 1 year ago #

    using wp 3.8.1 with wp advanced search 2 , the problem come when i made the change in the SEARCH.PHP and SEARCHFORM.PHP doing has it was suggested by the author.

    NOTE THAT FOR THE TEST I HAVE DISACTIVATE ALL PLUGINS EXCEPT ADVANCED SEARCH...

    i can login has administrator but i cant see the site's post and pageS anymore,,nothing, just the graphic

    i use twentyeleven template,

    this is my searchform
    <?php
    <div id="formulaire-recherche">
    <form method="get" id="searchform" action="<?php bloginfo('url'); ?>">
    <div id="recherche">
    <input type="text" name="s" id="s" value="" />
    <input type="submit" value="OK" id="bouton" />
    </div>
    </form>
    </div>
    ?>
    cause i keep "s" as id

    and this is 2 model of the search.php form

    1st MODEL /////////////////////

    /**
    * The template for displaying Search Results pages.
    *
    * @package WordPress
    * @subpackage Twenty_Eleven
    * @since Twenty Eleven 1.0
    */

    get_header(); ?>
    <div id="content">
    <div id="colleft">
    <?php WP_Advanced_Search(); ?>
    <div id="colright"><?php get_sidebar(); ?></div>
    <p class="clear"></p>
    </div>
    </div>

    <?php get_footer(); ?>

    2ND ) ////////////////////////THIS IS THE ORGINAL SEARCH EXECPT THE LOOP WAS REPLACED BY THE <?php WP_Advanced_Search(); ?>

    BUT PUTTING BACK THE 2 ORIGINAL FILES AND THE SITE RUN HAS BEFORE..
    THE PLUGIN IS ACTIVE

    <?php
    /**
    * The template for displaying Search Results pages.
    *
    * @package WordPress
    * @subpackage Twenty_Eleven
    * @since Twenty Eleven 1.0
    */

    get_header(); ?>

    <section id="primary">
    <div id="content" role="main">

    <?php if ( have_posts() ) : ?>

    <header class="page-header">
    <h1 class="page-title"><?php printf( __( 'Search Results for: %s', 'twentyeleven' ), '<span>' . get_search_query() . '</span>' ); ?></h1>
    </header>

    <?php twentyeleven_content_nav( 'nav-above' ); ?>

    <?php /* Start the Loop */ ?>
    <?php WP_Advanced_Search(); ?>

    <?php twentyeleven_content_nav( 'nav-below' ); ?>

    <?php else : ?>

    <article id="post-0" class="post no-results not-found">
    <header class="entry-header">
    <h1 class="entry-title"><?php _e( 'Nothing Found', 'twentyeleven' ); ?></h1>
    </header><!-- .entry-header -->

    <div class="entry-content">
    <p><?php _e( 'Sorry, but nothing matched your search criteria. Please try again with some different keywords.', 'twentyeleven' ); ?></p>
    <?php get_search_form(); ?>
    </div><!-- .entry-content -->
    </article><!-- #post-0 -->

    <?php endif; ?>

    </div><!-- #content -->
    </section><!-- #primary -->

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    //////////////////////////////////////
    so what can i do now..the theme used is running perfectly with a 20 active plugins yet and no problemo. but with these searchform nothing run anymore

    help will be appreciate

  5. mike022
    Member
    Posted 1 year ago #

    sorry, made a big mistake,..after reading again, it was more simple than the way i understood,

    i check name and id (s)

    and put <?php WP_Advanced_Search(); ?> after deleting all the <?php while ( have_posts() ) : the_post(); ?> loop

    i'll check if it works

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Advance WP Query Search Filter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.