WordPress.org

Forums

chmod messed up, internal server error (7 posts)

  1. tronicscribe
    Member
    Posted 6 years ago #

    I was changing my chmod settings for my WP install. previously I had not been aware of the importants and everything was set to 777. so I found the codex page explaining how to setup chmod for WP, and I followed it. however once I finished the changes, it gave me a forbidden access error. So I then changed everything back to 777, and now it says internal server error. what have I screwed up, and can this be fixed? thanks.

  2. whooami
    Member
    Posted 6 years ago #

    directorys: 755
    files: 644

  3. tronicscribe
    Member
    Posted 6 years ago #

    thanks, but I'm fairly certain I followed that structure based on the wp codex page about chmod, and yet it still gives me a server error. just to be clear, so I know I'm changing it right, directories would be any folder within root, correct? and I change only the folders chmod, or the folder and all sub folders and files? also on the codex page when it says set writable for only the user account, that means set "owner" writable in chmod, right? thanks again :D

  4. whooami
    Member
    Posted 6 years ago #

    you have files or folders or both at 777. thats the source of your error -- its an infrequent but safe set up that most hosts dont ascibe to (only the really good ones) -- apache wont let you have world writable files and folders.

    If you look in your error log, it will have told you this.

    as I stated, previously:

    directorys: 755
    files: 644

  5. tronicscribe
    Member
    Posted 6 years ago #

    ah thank you :D I didn't know about it disliking when both folders and files are world writable. I've now set them as they should be. thanks again.

  6. tronicscribe
    Member
    Posted 6 years ago #

    ah thank you very much for that info about it not liking both folders and files being 777. however, I notice you suggest dir. be 755 and files 644. but, in the codex it says to make certain folders and certain files set other ways than that. does it matter if the 755 folders are public executable? isn't it best not to allow any public file permissions if you dont need them? or are they needed here?

  7. whooami
    Member
    Posted 6 years ago #

    the executable flag applied to directories is fine -- it's what allows apache to 'move around' within the web space.

    there is nothing, as of my typing this, anywhere in the codex that suggests setting directory permissions at 6**

    Apache cant work like that.

    Ive provided you the proper permissions, and I'm out of different replies unless you want to 1) provide a link to the page in the codex you want to discuss further and 2) explain how it relates to what you are trying to accomplish.

  8. tronicscribe
    Member
    Posted 6 years ago #

    well thank you my good fellow with such a polite reply. anyway, I meant to imply that I got everything working fine with your wonderful advice on how to set folders and files. I most likely didn't explain myself clear enough when I was referencing the codex vs your advice.

    http://codex.wordpress.org/Changing_File_Permissions

    It doesn't actually say which *** number chmod to set, but I was pointing out such as for the admin folder it says to set it all file writable only on a user account. I took that to mean I only set the "owner" section of chmod to write, in which case would not result in a 755 or 644. so I was just trying to find out why the codex would suggest that, among other variations, and you would suggest as you did (which works exactly as it should, and I'm not to imply it is incorrect because I'm sure you know better than I). Anyway, again, thank you for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic