WordPress.org

Forums

WP eCommerce
[resolved] Cannot activate WPEC Version 3.8.13.3 (3 posts)

  1. halcyonweb
    Member
    Posted 1 year ago #

    I can't activate WPEC 3.8.13.3 after upgrade and get the following error message ...
    Plugin could not be activated because it triggered a fatal error.

    Warning: require_once(/home/user/public_html/wp-content/plugins/wp-e-commerce/wpsc-includes/wpsc-meta-init.php): failed to open stream: No such file or directory in /home/user/public_html/wp-content/plugins/wp-e-commerce/wpsc-updates/database_template.php on line 211

    Fatal error: require_once(): Failed opening required '/home/user/public_html/wp-content/plugins/wp-e-commerce/wpsc-includes/wpsc-meta-init.php' (include_path='/home/user/public_html/wp-content/plugins/google-analyticator/google-api-php-client/src:.:/opt/alt/php54/usr/share/pear:/opt/alt/php54/usr/share/php') in /home/user/public_html/wp-content/plugins/wp-e-commerce/wpsc-updates/database_template.php on line 211

    I tried deactivating all other plugins, still no success.
    Server system details:

    OS Type Linux platinum.netorigin.com.au 2.6.32-458.18.1.lve1.2.39.el6.x86_64 #1 SMP Mon Sep 16 12:10:28 EEST 2013 x86_64
    Server Software LiteSpeed
    Server Signature
    Server Name bindaree.com.au
    Server Address 118.127.40.11
    Server Port 80
    PHP Version 5.4.24
    Zend Version 2.4.0
    Platform 64Bit
    Loaded Extensions Core, date, ereg, libxml, openssl, pcre, sqlite3, zlib, bz2, calendar, ctype, curl, hash, filter, ftp, gettext, gmp, SPL, iconv, pcntl, Reflection, session, standard, shmop, SimpleXML, mbstring, tokenizer, xml, litespeed, bcmath, fileinfo, gd, imagick, intl, json, exif, mcrypt, mysql, mysqli, PDO, pdo_mysql, pdo_sqlite, posix, soap, suhosin, dom, xmlreader, xmlrpc, xmlwriter, zip, mhash, ionCube Loader, Zend Guard Loader
    MySQL Server 5.1.72-cll-lve
    Memory Limit 256 MB

    http://wordpress.org/plugins/wp-e-commerce/

  2. Jeff Pye Brook
    Member
    Posted 1 year ago #

    Looks like something went wrong when you downloaded and unpacked the plugin update. I double checked the zip file and the file in the error message is in the correct place.

    My suggestion is the following

      Make sure you have a valid backup of your site.
      Deactivate WP e-Commerce
      Manually delete the plugin files
      Re-download and Reinstall again.
  3. halcyonweb
    Member
    Posted 1 year ago #

    Thank you, this seems to have fixed the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic