WordPress.org

Forums

WP Ajaxify Comments
[resolved] Blank page after update (22 posts)

  1. LD Jackson
    Member
    Posted 1 year ago #

    I updated to the latest version of the plugin this morning, 0.21.0 and my home page comes up blank. If I enable debug mode, the page displays as it should.

    https://wordpress.org/plugins/wp-ajaxify-comments/

  2. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Could you please check you php error log?
    Is your WordPress site completely down or are there only some pages/URLs that shows only blank pages? Is the backend / admin page also down?

  3. LD Jackson
    Member
    Posted 1 year ago #

    It appears the only page that was down was the home page. The posts actually displayed correctly, as well as the admin page.

  4. LD Jackson
    Member
    Posted 1 year ago #

    I need to make a correction. The setting that makes my home page display correctly is the "always include scripts" setting. As soon as it is disabled, the home page is blank.

    I'm not sure where to find my php error log.

  5. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Is it possible to send me a link, where I can reproduce the problem?
    Do you see any JavaScript errors? The way php logs its errors (display error or logging to file) depends on your hosting setup. You may need to contact your system administrator to get detailed information ...

    Hope this helps,
    Jan

  6. LD Jackson
    Member
    Posted 1 year ago #

    The only way I can reproduce the problem is to uncheck the setting to always include scripts. If I do that, my homepage is blank. The link is below, but I have to check the setting so it isn't blank.

    http://www.ldjackson.net

  7. LD Jackson
    Member
    Posted 1 year ago #

    I'm not sure if this will help, but it is what I see in the console when I try to load the page.

    reflow: 0.58ms
    reflow: 0.3ms
    GET http://www.ldjackson.net/ [HTTP/1.1 200 OK 1460ms]
    reflow: 1.47ms
    reflow: 0.69ms
    reflow: 0.11ms
    reflow: 0.3ms
    GET http://www.ldjackson.net/ [HTTP/1.1 200 OK 808ms]
    reflow: 0.26ms
    reflow: 0.6ms
    Expected declaration but found '0'.  Skipped to next declaration. www.ldjackson.net:1
    Error in parsing value for 'margin'.  Declaration dropped. www.ldjackson.net:1
    Error in parsing value for 'padding'.  Declaration dropped. www.ldjackson.net:1
    Unknown property 'font-smooth'.  Declaration dropped. www.ldjackson.net:1
    Unknown property '-moz-border-radius'.  Declaration dropped. www.ldjackson.net:1
    Expected end of value but found '100%'.  Error in parsing value for 'width'.  Declaration dropped. www.ldjackson.net:1
    Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector. www.ldjackson.net:1
    reflow: 0.33ms function fillInPageTooltip, popup.xml line 605
    reflow: 0.38ms
    reflow: 0.33ms
    reflow: 1.03ms
    reflow: 0.5ms
    POST http://www.ldjackson.net/wp-admin/admin-ajax.php [HTTP/1.1 200 OK 839ms]
  8. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Could you please send me a lost of options that you have set on the plugin's setting page?

  9. LD Jackson
    Member
    Posted 1 year ago #

    ALWAYS INCLUDES SCRIPTS IS CHECKED.

    Everything else not checked, other than the box to enable the plugin.

    COMMENTS CONTAINER SELECTOR = #commentsWrapper

    'OnBeforeSelectElements' callback = (jQuery('td#middle > #comments', dom).length > 0) ?
    jQuery('td#middle > #comments, ul.commentlist', dom).wrapAll('<div id="commentsWrapper" />')
    : jQuery('<div id="commentsWrapper" />').insertBefore(jQuery('#respond', dom));

  10. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have a test environment where you can disable the "ALWAYS INCLUDES SCRIPTS" and send me a link to reproduce the problem?
    If not: Could you please disable the "ALWAYS INCLUDES SCRIPTS" and send ma a copy of the "blank page" (HTML including alls loaded assets)?

    Thanks
    Jan

  11. LD Jackson
    Member
    Posted 1 year ago #

    I do not have a test environment.

    Are you wanting a copy of the page source of the blank page?

  12. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Does the blank page really has a page size of 0 bytes, i.e. the webserver returns no content?
    If yes, you need to take a look into the PHP error log? Or is it possible to send me a backup of your blog page? At the moment, I've no idea what could break your start page...

  13. LD Jackson
    Member
    Posted 1 year ago #

    I disabled my plugins and the problem still persists. When I enabled the default theme, it went away. So, it has to be a conflict with Atahualpa.

  14. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your feedback. If the problem still exists after disabling the plugin, there needs to be another cause (maybe the theme or another plugin)...

  15. LD Jackson
    Member
    Posted 1 year ago #

    Let me clarify something. The problem still persisted, even after I disabled all plugins. I re enabled them and then enabled the default them. That's when the problem went away. As soon as I went back to Atahualpa, the problem reappeared.

    For what it's worth, a blogger friend of mine uses Atahualpa and WP-Ajaxify-Comments and he is not having the same problem.

    The plugin is still working, as I am using Always Include Scripts. Maybe it will sort itself out.

  16. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, I've no idea what could cause the problem without being able to reproduce it...

  17. LD Jackson
    Member
    Posted 1 year ago #

    Would it help if you had admin access to the blog? I could create a temporary account, if that would help. All I would need is an email address.

  18. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    You can send me a private message here: http://blog.janjonas.net/contact.
    Please also send me a short step by step introduction how to reproduce the problem...

  19. LD Jackson
    Member
    Posted 1 year ago #

    I have sent you the login credentials via your contact page.

  20. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your message. I've added a minor improvment to my plugin that fixe your problem. This fix is already applied on your site and will be included in the next release.
    Nevertheless, there seems to be something broken in your WordPress installation.

    global $post;
    get_comments_number($post->ID);

    stops the script execution.

    Hope this helps...

  21. LD Jackson
    Member
    Posted 1 year ago #

    Is it something with the theme installation? It does have a couple of modifications that force the trackbacks/pingbacks to display separately from the comments. Could that be the culprit?

    Thanks for checking it out for me. I do appreciate the effort you put into your plugin, even if it isn't necessarily your plugin that is at fault.

  22. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    I will mark this topic as resolved. As I've written in my email the problem is not caused by my plugin and I need a backup of your environment to to some further examinations.

    Best regards,
    Jan

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Ajaxify Comments
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.