• Resolved udbytossen

    (@udbytossen)


    Hi Forum.
    Using Latest WordPress I’m experiencing some troubles using a external mailserver directly ( changed after beeing hacket a few times)

    Normally I’m using port 587 with authentication.
    But whenever/whatever I’m trying – I’m getting this error:

    connect from SERV02.lan[172.16.10.110]
    Jul 28 17:04:18 serv01 postfix/smtpd[9481]: SSL_accept error from SERV02.lan[172.16.10.110]: 0
    Jul 28 17:04:18 serv01 postfix/smtpd[9481]: warning: TLS library problem: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1294:SSL alert number 48:
    Jul 28 17:04:18 serv01 postfix/smtpd[9481]: lost connection after STARTTLS from SERV02.lan[172.16.10.110]

    Thats even when no encryption selected – So what causing this problem and howto fix it

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator James Huff

    (@macmanx)

    What plugin are you using to tie into an external mailserver? If it’s not modified with a plugin, WordPress can only use PHP’s mail() function, which uses the local mailserver.

    Thread Starter udbytossen

    (@udbytossen)

    I’ve actually tried a coouple – but still gets the same error ( no problems from m y Concrete5 sites)

    I’ve tried the following plugins:
    WP Mail From II
    WP-SMTP-MAIL-CONFIG
    WP-Mail-SMTP

    But no luck getting the mail send through external mailserver

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Volunteer Forum Moderator

    Are you using the latest openSSL libraries on your server? It appears that there’s an issue with the TLS connections. This is a server configuration issue.

    Thread Starter udbytossen

    (@udbytossen)

    <Yes I’m using openSSL – Do you have the solution for this

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Volunteer Forum Moderator

    I asked whether the latest libraries were installed; I suspect that you’re using either an old version or accepting now invalid protocols, but this is not a WordPress issue. It’s a sysadmin thing.

    Thread Starter udbytossen

    (@udbytossen)

    Running Debian Jessie with the latest Libraries ( dev)

    I just haven’t been a problem before !

    Moderator James Huff

    (@macmanx)

    I agree with Steve, this is not a WordPress problem, so there isn’t much we can help with here. I recommend contacting your hosting provider’s support.

    Thread Starter udbytossen

    (@udbytossen)

    Well – INstalling postmaster plugin . and it runs smoothly – So IT is a WordPress problem !

    Moderator James Huff

    (@macmanx)

    Do you mean https://wordpress.org/plugins/postman-smtp/ ? If so, I suggest you continue to use it. It’s quite good.

Viewing 9 replies - 1 through 9 (of 9 total)

The topic ‘External Mailserver troubles’ is closed to new replies.