• drew

    (@drewdrewchristophercom)


    As a Super Admin on a WordPress Multisite installation, I’ve encountered several issues when using Wordfence passkey authentication. These issues appear to affect the Multisite environment specifically.

    When a passkey is enabled for my Super Admin account, the WordPress Admin Bar does not appear on the frontend while I’m logged in. Additionally, when I edit an existing page or post and select Preview Changes, WordPress returns the error:

    “Sorry, you are not allowed to preview drafts.”

    I was able to reproduce the issue consistently. When I remove the passkey, the Admin Bar returns and Preview Changes works normally. When I add the passkey again, the problems return.

    My Super Admin permissions remain intact, and normal access to the WordPress dashboard, Pages, Plugins, Users, etc. is unaffected.

    This appears to be related to authentication/session handling with passkeys on WordPress Multisite.

Viewing 1 replies (of 1 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @drewdrewchristophercom, sorry to see you’re having trouble.

    Could I just double-check if you’re using any custom role editor or membership plugin to change anything about the permissions a Super Admin has, or is it totally standard? I appreciate the Preview Changes error doesn’t look browser-specific, but did you happen to run any tests to see if the admin bar issue presented across different browsers?

    It may assist us in this case to see a report from the master site’s Wordfence > Tools > Diagnostics menu. You can send that to us at wftest @ wordfence . com. Click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    NOTE: It should look as follows – Screenshot of Tools > Diagnostic > Send by Email

    Thanks,
    Peter.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.