• Resolved rogersundstrom

    (@rogersundstrom)


    I’ve run into problems with my site after upgrading WordPress and PHP.
    WordPress 7.1.1, PHP 7.4.33 and Pods 2.9.19.5

    The issue now is that I cannot manage my Pods fields, they aren’t displaying, and the problem appears to be related to JavaScript.
    I’m getting the following error, Incorrect use of < label for=FORM_ELEMENT >

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support pd

    (@pdclark)

    Are there any other errors or warnings, especially in PHP error logs?

    The JavaScript error means there is a <label for="ID_OF_INPUT_OR_SELECT"> element on the page, but a matching form field with id="ID_OF_INPUT_OR_SELECT" was not found not the page… it generally means what you already observed: the form field is not on the page.

    The recent changes in that point update were security and output-sanitization related… unless there is more specific information, one known issue which might be related would be to verify labels of Field Groups and Fields do not contain any non-ASCII characters.

    Thread Starter rogersundstrom

    (@rogersundstrom)

    I also get the same error under Pods Admin and settings.
    I can’t access my fields there either, so I think the problem is something else.

    Plugin Support pd

    (@pdclark)

    If there are no 404’s reported in Web Inspector Network tab, try clearing browser cache (shift-reload) and any CDN cache if in use (Cloudflare, Host, Caching plugins), as fields can sometimes not load after an update if the old version of field scripts are still loading.

    Thread Starter rogersundstrom

    (@rogersundstrom)

    I have cleared the browser cache and the cache at my webb hosting with no luck.

    I ran a quick test by installing LocalWP on my local computer with WordPress 7.1.1 and an empty Pods 2.9.19.5. and I get the same phenomenon with the fields. Then I tried upgrading the Pods version on my computer to the latest one, and the fields started working again.
    It must have something to do with the WordPress upgrade.

    Thread Starter rogersundstrom

    (@rogersundstrom)

    I upgraded to the latest version of Pods on the web host and migrated my PHP scripts to files, then I had to fix a few errors in the PHP code. Now everything is working again 🙂

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.