Plugin Support
wfphil
(@wfphil)
Hi @dicomptech
You must have at least Wordfence version 7.2.1 installed to be able to connect a site to Wordfence Central. Please update to the latest version 7.4.0
Please send me an email to wftest [@] wordfence [.] com from the email address that you used to register your Wordfence Central account. Put @dicomptech in the subject field so that I can find it. I need your email address to be able to find your account.
Reply here when the email has been sent and I will find it and take a look at the errors for you.
Thanks.
Hi wfphil
Thank you for your reply. E-mail has been send with requested subject.
Thanks
Plugin Support
wfphil
(@wfphil)
Hi @dicomptech
Thank you for the update.
I see no sites listed under the Connection Issues tab in your Wordfence Central account. Please add the sites again and if they don’t connect then don’t remove them as I need to see the error messages under the Connection Issues tab, and I also need to know the domain names so that I can run some tests.
Thank you.
Hi @wfphil
Thanks. I managed to connect 3 today which were strangely not able too yesterday, however the rest that I’m trying to add still fail with the Connection Issue Error. I’m unable to even add them to Central at all.
I’ve send you a mail with a few domain examples.
Thanks alot for your help.
Cheers
Plugin Support
wfphil
(@wfphil)
Hi @dicomptech
Thank you for the update.
For the sample of 4 sites that you sent me they all appear to be using a maintenance mode plugin which is blocking WordPress REST API functionality.
Please disable the maintenance mode plugin before connecting the sites to Wordfence Central.
Hi @wfphil
Awesome, thank you for your help on this. This indeed seems to be the challenge. The plugin is ManageWP’s Worker. I deactivated one and managed to add it to WFC. However after activating the Plugin again, the connection was refused.
What would be the best approach to tackle this if possible? Would there be a workaround to enable 2 Plugins to use the REST API simultaneously?
Thanks
Plugin Support
wfphil
(@wfphil)
Hi @dicomptech
Thank you for the update
I believe you are using the ManageWP Maintenance Mode function that appears to disable WordPress REST API functionality. Check with their support if that is the case, and if there is a setting you can toggle to allow full WordPress REST API functionality.
HI @wfphil
Thank you very much for your Support. I will engage with the ManageWP Team and see whether we can rectify this.
Once again, thank you for assisting.
Cheers