This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Description

wpSearchMu is a very powerful search plugin for WordPress Mu. It is based on the open source search engine “Lucene” which means its fast and relevant. If you need an awesome blog search, you’ve come to the right place.

The major features of wpSearchMu are:

* Each blog can setup wpSearchMu for /just/ their blog's search * Index and search all/some/one of the WordPress Mu blogs * Unmatched and customizable search relevancy (thats the power of Lucene!) * Very fast search speed * Wildcard and Boolean operator support * Easy installation * Instantly updated searching after a post has been written * Searching of Posts and Pages * Integration into any blog * No javascript / css includes * Optimized integration into the WordPress search mechanism * Searching of comments * Foreign character support 

Features for advanced users:

* Access to an internal search service for extendability 

Requirements:

* WordPress Mu version 2.2.x or higher. * PHP 5 or higher (PHP 4.4.8 will throw parsing errors) * The iconv library (Usually installed/enabled on a server by default) 

FAQ

  1. Q: I get an error that says something like:

Parse error: syntax error, unexpected T_STRING, expecting ‘{‘ in /homepages/18/d179583305/htdocs/MLL-site/book/wp-content/plugins/wpsearch/Zend/Search/Lucene.php on line 82

What’s going on?

  1. A: This means you are using PHP 4.x.x or lower. The search library underneath wpSearch needs PHP 5 or higher to run.

  2. Q: Where do I send bug reports to?

  3. A: wpSearch is still young, so there may be a few unforeseen issues when wpSearch makes its appearance in a world of different WP versions, PHP versions, etc. Send all bug reports to katzgrau@gmail.com .

Contributors & Developers

This is open source software. The following people have contributed to this plugin.

Browse the code