This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WP Present – beta

Description

Create an Account or checkout the new DEMO: http://wppresent.com

Want to help out? Check out the Developer Notes

Create interactive slide presentations, the WordPress way.

Presentation layer powered by reveal.js from Hakim El Hattab (http://hakim.se).

Currently works best with Chrome & Safari

If you’d like to contribute to the plugin you can find it on GitHub: https://github.com/stevenkword/WP-Present

Developers

  • Stable branch, master, is version 0.9.6 and is only compatible up to WordPress 3.8 due to a problem introduced in WordPress 3.9 with the TinyMCE 4.0 Update. See Issue #8
  • Development against WordPress 3.9+ should be done against the development branch on GitHub

Screenshots

  • The admin interface
  • A slide in a presentation
  • Presentation editor

Installation

  1. Upload “/wp-present” to the “/wp-content/plugins/” directory.
  2. Activate the plugin through the “Plugins” menu in WordPress.

Contributors & Developers

“WP Present – beta” is open source software. The following people have contributed to this plugin.

Contributors

Translate “WP Present – beta” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

0.9.7

  • Rewrites modal editor for 4.0 compatibility

0.9.6

  • Supports the ability to overwrite plugin template with theme templates
  • JS script inclusion audit
  • Adds shortcode for embedding WP Present into posts
  • Updates donate buttons and links
  • Tabifies the settings page
  • More informative AJAX spinners
  • Adds Templates for individual slides
  • Enqueues Dashicons always
  • Adds taxonomy bridge for storing additional taxonomy information in custom post types
  • Updates admin menus
  • Fixes color saving on Publish in modal customizer

0.9.5

  • Emergency patches to fix support in preparation for WordPress 3.8

0.9.4

  • I did things