WordPress.org

Plugin Directory

WP Native Dashboard

Enables selection of administration language either by logon, dashboard quick switcher or user profile setting.

This plugin enables the selection of your prefered language the dashboard (and whole administration) will be shown during your work. Several options can be enabled and also combinations out of:

  1. logon screen extension - user can specify his/her prefered language during logon
  2. dashboard quick switcher extension - user can easily switch language at every admin page
  3. WordPress admin bar switcher - user can switch at active admin bar the language as usual
  4. BuddyPress admin bar switcher - user can switch at active admin bar the language as usual
  5. user profile setting - each user can define at profile his/her prefered language

The plugin also includes a repository scan on demand (svn.automattic.com) for available language file downloads. You can download the required files into your installation and immediately use them at admin pages. The new administration page is restricted to administrators only, the profile setting also work for subscriber. The dashboard quick switcher handling has been changed startion WordPress version 3.0 because there is no longer a header. You can use the quickswitcher at the admin bar anyway, this is prefered use case at higher versions of WordPress.

Download and File Management

Starting with version 1.1.0 of this plugin it uses now the WordPress build-in file management from core. If the plugin detects, that you are not permitted to write directly to disk, it uses the FTP user credentials for download and remove of language files.

WordPress / WPMU and BuddyPress

If you have a local WordPress community providing their own download repository for language files, please let me know, if you would like to get it integrated. Because i didn't found an official language file repository for BuddyPress and WPMU, it currently only permits WordPress language file downloads. If you have more specific informations about, please let me know, it's easy to integrate a new download section (also with detection the kind of WP).

Requirements

  1. WordPress version 2.7 and later
  2. PHP Interpreter version 4.4.2 or later

Please visit the official website for further details, documentation and the latest information on this plugin.

Requires: 2.7 or higher
Compatible up to: 3.6.1
Last Updated: 2013-8-7
Active Installs: 20,000+

Ratings

4.7 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
100,1,1
100,3,3
100,1,1 67,3,2
100,1,1
100,4,4
100,2,2
80,5,4 100,1,1
100,2,2 100,1,1
100,2,2 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,8,8
60,5,3
33,3,1 100,2,2 100,1,1
75,4,3
100,5,5 100,1,1
67,3,2 50,2,1
100,3,3
50,2,1
0,17,0 100,7,7
100,1,1
100,4,4
50,2,1
100,1,1
100,1,1
50,2,1
50,2,1
50,6,3
100,1,1
50,6,3
33,3,1