WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

WP Blockade - Visual Page Builder

Blockade is the WordPress editor done right. It's a lightweight, flexible visual page builder that lets you build stunning layouts in seconds.

Blockade is in public beta. There may be frequent releases and features may change as we work towards releasing version 1.0. Please let us know about your experience, so we can make Blockade even better.

Blockade will change the way you look at designing and building for the web

Page builders are usually overbuilt and hard to learn to use effectively. Blockade turns that trend on its head, and provides a lightweight page builder that integrates directly into your site's existing interface. With Blockade, you can build beautiful, professional, and standards-compliant responsive layouts, in seconds.

Want to know the best part? Your layout is built in clean, easy to edit HTML5, with the popular Bootstrap framework. Need to make a change beyond what the interface allows? Simply switch to text mode and edit the HTML directly.

Built for real designers with real clients

Real clients have sites with custom metaboxes, shortcodes, widgets, and theme options built into their editors. Most page builders ignore those crucial controls, and focus on building a new interface, just for their custom experience. They aren't good at being a tool that adds to an existing workflow.

We built Blockade to give our clients the WordPress experience they deserve. It cut its teeth on the real problems users face with designing and editing, and working with common plugins like ACF and Slider Revolution. It has revolutionized editing for our team and our clients.

Now we're ready to revolutionize editing for everyone else.

Learn more at https://www.wpblockade.com

Blockade Features

  • Content Blocks: HTML, Photo, Video, Button, Text & Map
  • Structure Blocks: Simple Columns, Groups, and Full-Width Breakouts
  • Lightweight, semantic markup for maximum performance and accessibility
  • Easy background controls
  • Mobile-friendly, responsive layouts
  • Add your own CSS classes and IDs
  • Embed shortcodes as usual
  • Works with Pages, Posts, and Custom Post Types
  • Flexible API for custom addon development

Requires: 4.0 or higher
Compatible up to: 4.7.2
Last Updated: 1 month ago
Active Installs: 90+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.