WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WordPress Mobile Pack

The NEW WordPress Mobile Pack allows you to 'package' your existing content into a cross-platform mobile web application.

Setting up cache plugins for working with WordPress Mobile Pack

If your site uses a cache plugin, please note that a series of issues can occur if that plugin wasn't configured to work with WordPress Mobile Pack. Some examples are:

  • Loading the mobile web application on desktop browsers
  • Loading the desktop theme on a supported mobile device (even though the WordPress Mobile Pack plugin is active)
  • Inconsistent switching between the desktop and the WordPress Mobile Pack theme

If you find yourself in one of these situation, please read the docs and make the appropiate settings on your cache plugin.

Roadmap

Our roadmap currently includes:

  • Integrating with Disqus
  • RTL support
  • Localization. Please contact us if you can help by translating the mobile web application's text into your language.
  • Integrating with the most popular forms plugins

Known issues and limitations for v2.1

  • V2.1 of the mobile web app doesn't include support for forms. We are looking for a way to recreate forms inside the mobile web application and integrate with various plugins.
  • Iframes are not currently supported because of scrolling issues on iPhone.
  • The mobile web app doesn't include user authentication. If your blog settings enable comments only for logged in users, they will be disabled in the mobile web app.
  • For now, supported mobile browsers include Safari, Google Chrome, Android's native browser, Internet Explorer 10 and Firefox (as of 2.0.2). Support for other mobile browsers such as Opera will be added in the following versions.
  • Only featured images from your blog posts are displayed as thumbnails in the list of posts. Images integrated in a post's content are displayed only on the details page for that post.

Repositories

We currently have two Github development repositories:

Requires: 3.5 or higher
Compatible up to: 4.0.1
Last Updated: 2015-2-16
Downloads: 690,532

Ratings

2.8 out of 5 stars

Support

0 of 6 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,2,2
100,1,1 100,3,3 50,2,1 100,1,1 50,2,1 100,1,1 100,1,1
100,2,2 100,1,1 100,1,1 80,5,4
100,1,1 92,13,12 0,5,0 100,4,4
88,17,15 79,14,11 50,2,1 100,3,3
100,1,1 86,7,6 93,15,14 100,1,1
61,33,20 100,1,1
67,6,4
86,7,6
100,3,3
55,38,21
100,8,8
56,9,5
14,7,1
0,2,0
55,33,18
38,8,3
61,31,19 100,1,1
91,11,10 100,1,1
100,2,2
0,2,0 41,17,7
64,11,7
100,1,1
64,11,7
0,1,0
0,1,0
0,1,0
100,1,1
0,1,0
0,1,0 0,2,0
100,1,1
67,3,2