WordPress.org

Plugin Directory

WooCommerce · Beans · Loyalty & Reward Program

Simple, non-intrusive, and efficient loyalty and reward program for woocommerce retailers.

We’re on a mission to make your loyalty and rewards program simpler, more pleasant and more productive.

Beans is a beautiful and powerful loyalty and reward program that helps you improve long term engagement and promote your business by increasing customers interactions with your organization.

http://youtu.be/ccnwolJ3uWw

Rules

Beans works with the services that your business already uses! With Beans, you can incentivize your customers for doing whatever matters to your business, for example:

  • When they subscribe to your reward Program.
  • When they make a purchase.
  • When they like your Facebook page.
  • and more...

See our full list of rules

Discovery

When you create a reward program with Beans it will be promoted on Beans Platform and indexed on Search Engine (Google, Bing, Yahoo Search...).

Your beans page (like your Facebook page, Twitter page or PInterest page) becomes a showcase for your business to drive new sales and increase your digital footprint.

See who else is using Beans

Features

  • Install any rule in a few clicks
  • Create your own rules
  • Customize you beans name
  • Email notifications for your customers
  • Make manual credit or debit from beans interface
  • Powerful analytics to help you measure your performance
  • Set max/min beans redeem per order
  • Fraud detection system
  • And more...

Read more about Beans

Premium

Beans is free to use for as long as you want and with an unlimited number of customers. But if you want to take full advantage of Beans and customize it with your branding you can try one of our premium package.

PS: This is the beta version of Beans. New features are added on a weekly basis and a few bugs may happen. Do not forget to file a bug report if you encounter any issue. You can also contact us directly at hello*trybeans.com

  • Internationalization is supported, please check FAQ
  • All currencies are supported!

Requires: 4.0 or higher
Compatible up to: 4.2.1
Last Updated: 2015-5-2
Active Installs: 60+

Ratings

4 out of 5 stars

Support

1 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.