WordPress.org

Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WooCommerce API Lockdown

Protect your data by restricting what is available through your WooCommerce REST API on a site wide or per user basis.

While WooCommerce's REST Api (v2.1+) allows easy integration with your favorite 3rd party services, it also opens the doors for users to access all of your store details including:

  • Order Details
  • Customer Details
  • Product Information
  • Coupon Codes
  • Store Reports

WooCommerce API Lockdown allows you to restrict what is available through your API on a site wide or per user basis with an easy to use admin panel.

Usage

  1. Once installed, in your WordPress backend navigate to to 'WooCommerce' -> 'API Lockdown'
  2. Select any site wide restrictions
  3. Select any users specific restrictions
  4. Click update that that's it.

What Happens when a Restricted User Tries to Gain Access?

If a user tries to access a section they don't have access to they will simply get a Authentication Error.

Plugin's Official Documentation and Support Page

Requires: 2.3 or higher
Compatible up to: 3.81
Last Updated: 2 years ago
Active Installs: 50+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.