WordPress.org

Plugin Directory

Weaver Xtreme Theme Support

A useful shortcode and widget collection for Weaver Xtreme

This is the main theme suppot for the Weaver X Theme. This plugin provides a collection of useful shortcodes and widgets designed to complement the Weaver X theme. These shortcodes have been selected and developed based on requests and feedback from thousands of users of the Weaver X, Weaver II, and Aspen themes.

While these shortcodes are optimized for the Weaver X theme, they will also work with full functionality for most WordPress themes, and can be used if you switch themes.

Includes complete documentation help file. Instructions for using the shortcodes and widgets are in the help file. Use it for non-Weaver Xtreme themes.

Shortcodes included

  • [tab_group] - Display content in a tabbed box.
  • [youtube ] - Show your YouTube videos responsively, and with the capability to use any of the YouTube custom display options.
  • [vimeo ] - Show your Vimeo videos responsively, and with the capability to use any of the Vimeo custom display options.
  • [iframe] - Quick and easy display of content in an iframe.
  • [div], [span], [html] - Add div, span, and other html to pages/posts without the need to switch to Text view.
  • [hide/show_if] - Show or hide content depending upon options: device, page ID, user capability, logged in status.
  • [bloginfo] - Display any information available from WordPress bloginfo function.
  • [user_can] - Display content base on logged in user role.
  • [site_title] - Display Site title.
  • [site_tagline] - Display Site tag line.

Widgets Included

  • Weaver X 2 Column Text Widget - Add text into two columns in a widget
  • Weaver X Per Page Text Widget - Add a text widget on a per page basis
  • Weaver X Login - Simplified login widget

Licenses

  • The Weaver X Theme Support plugin is licensed under the terms of the GNU GENERAL PUBLIC LICENSE, Version 2, June 1991. (GPL) The full text of the license is in the license.txt file.
  • All images included with this plugin are either original works of the author which have been placed into the public domain, or have been derived from other public domain sources, and thus need no license. (This does not include the images provided with any of the below listed scripts and libraries. Those images are covered by their respective licenses.)

This plugin also includes several scripts and libraries that are covered under the terms of their own licenses in the listed files in the plugin distribution:

Requires: 4.0 or higher
Compatible up to: 4.2.2
Last Updated: 2015-5-31
Active Installs: 5,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1