Version Control for jQuery

Description

Version Control for jQuery is the easiest way to control the version of jQuery used on your website. Whether you just want to run a stable WordPress website, or if you are a developer and want to cross check your website with the various version of jQuery, the plugin will always have the latest minified version of jQuery ready for you, loaded from the super-fast jQuery CDN. The plugin will default to the latest pre-release of both jQuery Core and jQuery Migrate, but this can easily be changed from the settings page, in case you prefer to use the latest official release.

Please notice that no files are replaced, therefore deactivation of this plugin returns your site to it’s original state.

Like the plugin?

If you like the plugin, please review it! Every review is highly appreciated, but if you want to suggest something, please send an email to info@carpe-noctem.no.

Installation

  1. Upload version-control-for-jquery/ to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Sit back and enjoy, or select your desired version of jQuery

FAQ

Installation Instructions
  1. Upload version-control-for-jquery/ to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Sit back and enjoy, or select your desired version of jQuery

Reviews

Read all 3 reviews

Contributors & Developers

“Version Control for jQuery” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

1.0.8

  • jQuery Core versions 3.3.0 and 3.3.1 have been added.
  • Minor adjustments.

1.0.7

  • Minor adjustments.
  • Support for WordPress 4.9.

1.0.6

  • jQuery Migrate version 3.0.1 has been added.

1.0.5

  • A bug that caused jQuery Core and jQuery Migrate to be dequeued while logged in to the admin area has now been resolved.

1.0.4

  • Added the pre-versions of jQuery Core version 3.2.2 and jQuery Migrate version 3.0.1, in case you want to test your website with the upcoming versions of jQuery. The plugin still defaults to the latest stable version of jQuery.

1.0.3

  • jQuery Core versions 3.2.0 and 3.2.1 have been added.

1.0.2

  • Corrected the way of requiring the “Settings” page. Thanks to Ivaylo Draganov for noticing!
  • Minor adjustments.

1.0.1

  • jQuery Core version 3.1.1 has been added.
  • The plugin now supports the Norwegian language.

1.0

  • Initial release