Update Message

Description

Add an update box in posts.

This box can contain a message, for instance in order to point out that the post have been modified of to stress that the post in no longer up to date

The message can be configured direcly when editing a post. There is a box ‘Update message’ added on the left.

In addition, you may use a shortcode [maj update=’dd/mm/yy’ expire=’dd/mm/yy’]xxx[/maj]

Plugin developped from the orginal plugin WP Update Message.

This plugin is under GPL licence.

Multisite – WordPress MU

This plugin works with multisite installation of WordPress.

Localization

  • German (Germany) translation provided by klotzi703611, RobertBergholz
  • Greek (Greece) translation provided by skyrodos
  • English (United States), default language
  • Spanish (Spain) translation provided by BrenardCrespo, notaspampeanas
  • French (France) translation provided by SedLex
  • Italian (Italy) translation provided by DarioDaniele, Androidous
  • Dutch (Netherlands) translation provided by MichaelWijnands
  • Polish (Poland) translation provided by Kajaczek
  • Portuguese (Portugal) translation provided by PedroNave
  • Russian (Russia) translation provided by MegaJeme, RobertBergholz
  • Turkish (Turkey) translation provided by kbasali
  • Chinese (People’s Republic of China) translation provided by wensonjo

Features of the framework

This plugin uses the SL framework. This framework eases the creation of new plugins by providing tools and frames (see dev-toolbox plugin for more info).

You may easily translate the text of the plugin and submit it to the developer, send a feedback, or choose the location of the plugin in the admin panel.

Have fun !

Screenshots

  • The configuration page of the plugin
  • An example of an update box
  • Configuration of the update box in a post

Installation

  1. Upload this folder update-message to your plugin directory (for instance ‘/wp-content/plugins/’)
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Navigate to the ‘SL plugins’ box
  4. All plugins developed with the SL core will be listed in this box
  5. Enjoy !

FAQ

  • Where can I read more?

Visit http://www.sedlex.fr/cote_geek/

InfoVersion:432c1d750b5cf7948316251852dca9e78dc4d509

Reviews

Works!

Thank you for developing this straightforward plugin.

This plugin allows you to post messages to your readers regarding your posts updates to the top or bottom of your post.

The updates are displayed in a nice yellow highlighted box via input in a field on the edit screen.

Read all 3 reviews

Contributors & Developers

“Update Message” is open source software. The following people have contributed to this plugin.

Contributors

Translate “Update Message” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.3.7

  • NEW: Update of the core

1.3.6

  • NEW: icons
  • NEW: delete contet on uninstall

1.3.5

  • NEW: How to

1.3.4

  • NEW: Improve the look of the plugin

1.3.3

  • Few enhancements

1.3.2

  • BUG : split is deprecated in PHP 5.3.0

1.3.1

  • Issue solved with the published date

1.3.0

  • Expiration date now possible in the shortcode
  • HTTPS now supported

1.2.0 -> 1.2.10

  • Update core
  • Lighten the plugin and add translations
  • Issue with some installation with locale
  • Update the core
  • Correct a bug with some installation and the button
  • Enable the multisite
  • Add a button in the Editor
  • Enable the message in the excerpt
  • Update of the framework
  • The date format may be adapted. The format used will be the default wordpress format
  • Major release of the framework

1.1.0 -> 1.1.7

  • Greek translation (by skyrodos)
  • Improve English text thanks to Rene
  • German translation (by klotzi703611)
  • Polish translation (by Kajaczek)
  • Netherlands translation (by MichaelWijnands)
  • Update of the core
  • Portugese translation (by PedroNave)
  • SVN support

1.0.0 -> 1.0.6

  • Update of the core
  • ZipArchive class has been suppressed and pclzip is used instead
  • Ensure that folders and files permissions are correct for an adequate behavior
  • The update message may be integrated with a shortcode [maj]
  • Enhance translations, feedback and other plugins
  • Update of the framework (3.0)
  • First release in the wild web (enjoy)